PDA

View Full Version : multiple mysqld processes



lsimon4180
3rd October 2004, 06:09 PM
Hey all,

I am running Fedora2 with mysql 4.0.21-standard and im noticing strange things with mysql.

I origianlly had mysql 3.23 then tried to get 4.0.21 installed and finally did but mysql 4 isnt acting like it should.

If I type 'service mysqld start' to start it and then i type 'mysql' and im in!

But, i also typed 'ps -A |grep mysqld*' to see how many processes there are and i see about 10!

28515 tty1 00:00:00 mysqld_safe
28547 tty1 00:00:00 mysqld
28548 tty1 00:00:00 mysqld
28549 tty1 00:00:00 mysqld
28550 tty1 00:00:00 mysqld
28551 tty1 00:00:00 mysqld
28552 tty1 00:00:00 mysqld
28553 tty1 00:00:00 mysqld
28554 tty1 00:00:00 mysqld
28555 tty1 00:00:00 mysqld
28556 tty1 00:00:00 mysqld

i run killall mysqld a few times and it finally kils them all but i try to start the service again and the 10 processes appear.

another thing is. I dont see mysqld running when i type 'top' to view the processes?

Is there something different with 4.0.21-standard?

i looked at some threads that are related and I checked perms on most of the mysql files and they are owned my mysql...the only file that is owned by root is mysqld_safe.

any ideas?

Thanks,

lenny

crackers
3rd October 2004, 08:06 PM
It appears that MySQL spawns off multiple processes to deal with multiple connections to the database. And the reason you may not see them in top is because a) they're not the top memory users or b) they're not the top CPU users. They're probably listed much further down the process list.

Jman
4th October 2004, 04:10 AM
I think that having a few threads ready for connections is normal behavior.

Tip for top: press u and then mysql to limit the processes to those owned by mysql.