PDA

View Full Version : samba problem can see windows folders but cant open them



paxromana
3rd October 2004, 09:07 AM
hi all, im new to linux and i configured samba
i am able to browse the windows computer and i see the folders that i shared in my shared documents folder, but i am unable to open the folders and see then contents.

any ideas?


thanks

superbnerd
3rd October 2004, 10:12 AM
Details...
Why can't you open the folders and file? Is there an error message? Do you have samba users setup? Are you using "share" level security?

paxromana
3rd October 2004, 11:41 AM
i am using user security

when i try

smbclient \\\\spion\\
Password:

i get

Domain=[SPION] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

i used firefox and typed in this smb://spion
and i can see all the shared folders

but i cant open them

is there a property i need to set in the config file so i can see files or anythin like that

any ideas?

thanks

jayemef
4th October 2004, 03:42 AM
First of all, is the login name you are using on your linux machine the same as it is in your windows machine? Most of the time it is not, in which case you would use the -u or --user= arguments to specify your username. Also, in order to connect with smbclient, you generally need to know the computer name as well as the share name. So first try this:


smbclient -L //compname/ --user=username

If you're prompted for a password, just enter the password you use with that windows username. If the connection to the machine works, you will then be given a list of all the shares available on that particular machine. So lets say a directory named "shares" is available on that machine, and the machines name is spion. Then you would connect with the command


smbclient //spion/shares --user=username

If a connection is made, you can then type a question mark into the terminal to see the list of available commands. Hopefully this works for you...

paxromana
4th October 2004, 03:54 AM
i typed in

smbclient -L //spion --user enzo
Password:

and this is what i got, but i didnt get a samba terminal, it just went back to the regular shelll

Domain=[SPION] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

Sharename Type Comment
--------- ---- -------
IPC$ IPC Remote IPC
Documents Disk
print$ Disk Printer Drivers
phpsite Disk
php Disk
pics Disk
mysql Disk
ADMIN$ Disk Remote Admin
wwwroot$ Disk Used for file share access to web projects
C$ Disk Default share
phplearn Disk
Domain=[SPION] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

Server Comment
--------- -------

Workgroup Master
--------- -------

when i tried this

smbclient //spion/shares --user enzo
Password:

i got this error

Domain=[SPION] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

any ideas?

thanks

superbnerd
4th October 2004, 03:56 AM
With user securty, you need to setup samaba users. Did you do that? You now can use the system-config-samba tool under Main Menu > System Settings > Server Settings > Samba.

If that and the advice above don't work, you should check if it works with just Share level security.

paxromana
4th October 2004, 03:59 AM
NEVERMIND

i got it workin thanks for your help, i was trying to browse shares when the shares directory didnt exist, but i
got it workin thanks