PDA

View Full Version : Net-SNMP does not work after upgraded to FC11



christopherchiu
1st October 2009, 06:09 PM
I had FC 10 and net-snmp was working. I have upgraded to FC 11 and used yum to upgrade all the installed software. However, net-snmp still does not work.


[root@ChrisEngLinux ~]# snmpget
snmpget: error while loading shared libraries: libcrypto.so.7: cannot open shared object file: No such file or directory

openssl is installed.

[root@ChrisEngLinux /]# find . -name "libcrypto.so*"
./usr/lib64/libcrypto.so.8
./usr/lib64/libcrypto.so
./usr/lib64/libcrypto.so.0.9.8k

I guess net-snmp is pointing to libcrypto.so.7 and I have libcrypto.so.8 installed. Please advise on how to correct it. Thanks.