PDA

View Full Version : Frostwire leaves a ton of files behind after removal



Slinx
1st October 2009, 04:51 AM
Hey I got rid of frostwire for various reasons but I noticed when I go into terminal and type
$ locate frostwire
I still have a ton of files from it in there. Is there a command I can use to erase all of the files containing the text "frostwire" or "FrostWire" or do I have to manually track them down and delete them one at a time?
oh also I noticed that locate found a file I had deleted after I tried to shred remove just to experiment with that feature.

scottro
1st October 2009, 05:17 AM
I'd be careful. Also, did you rerun updatedb before doing locate frostwire. Unlike find (which takes much longer) locate works from a database, which is why it's so quick. The thing is though, if you did for example

touch myfile
updatedb
locate myfile
/home/slinx/myfile

Now
rm myfile
locate myfile
You'll see that locate still finds myfile

If you once again run updatedb and then try locate myfile, you'll see it's gone.

(If I'm telling you things you know, please forgive me, but sometimes folks don't know.)

Not knowing how you installed frostwire, I'll assume you did it through yum. I think there are various yum commands to locate files like that--that is, packages that were installed as dependencies of another package, but it's after midnight here, and the command escapes me.

However, you could also look through /var/yum/log and see what packages were installed when you installed frostwire. Sometimes it's obvious, especially if it's the only thing you installed through yum on a particular day. In that case, you could remove them (through yum) as well.

Slinx
1st October 2009, 09:35 AM
Hey thanks no I didn't know about updatedb I assume I have to sudo updatedb because it said

[slinx@localhost ~]$ updatedb
updatedb: can not open a temporary file for `/var/lib/mlocate/mlocate.db'

I actually installed it via the rpm at the frostwire site. I think I tried getting it from yum but it didnt find it so I just used the rpm.

scottro
1st October 2009, 09:43 AM
Just a quick look at the site indicates it might not be free (as in speech, not Free DIet Mountain Dew), software (though I am not sure about that.)
Yes, updatedb requires being root or having root privilege, e.g., with sudo.

Slinx
1st October 2009, 09:57 AM
Yeah I am not too sure about it either.. I uninstalled because im not sure if it caused it but I was using tcptrack and noticed that I was receiving a lot of syn_sent from an ip like every day even when I have nothing running that should be tracking back to a chinese ip address.

locate frostwire gives me this.. its after I removed it via rpm -e frostwire
[slinx@localhost ~]$ locate frostwire
/home/slinx/.frostwire4.18
/home/slinx/.frostwire4.18/.AppSpecialShare
/home/slinx/.frostwire4.18/.NetworkShare
/home/slinx/.frostwire4.18/createtimes.cache
/home/slinx/.frostwire4.18/downloads.dat
/home/slinx/.frostwire4.18/fileurns.bak
/home/slinx/.frostwire4.18/fileurns.cache
/home/slinx/.frostwire4.18/filters.props
/home/slinx/.frostwire4.18/frostwire.props
/home/slinx/.frostwire4.18/gnutella.net
/home/slinx/.frostwire4.18/installation.props
/home/slinx/.frostwire4.18/intent.props
/home/slinx/.frostwire4.18/library.dat
/home/slinx/.frostwire4.18/mojito.props
/home/slinx/.frostwire4.18/overlays
/home/slinx/.frostwire4.18/overlays.dat
/home/slinx/.frostwire4.18/questions.props
/home/slinx/.frostwire4.18/responses.cache
/home/slinx/.frostwire4.18/seenMessages.dat
/home/slinx/.frostwire4.18/spam.dat
/home/slinx/.frostwire4.18/tables.props
/home/slinx/.frostwire4.18/themes
/home/slinx/.frostwire4.18/ttrees.cache
/home/slinx/.frostwire4.18/ttroot.cache
/home/slinx/.frostwire4.18/version.xml
/home/slinx/.frostwire4.18/xml
/home/slinx/.frostwire4.18/.NetworkShare/Incomplete
/home/slinx/.frostwire4.18/.NetworkShare/Incomplete/T-4506256-LimeWireWin4.16.6.exe
/home/slinx/.frostwire4.18/overlays/default.png
/home/slinx/.frostwire4.18/overlays/espsix_older_is_better.jpg
/home/slinx/.frostwire4.18/themes/GTK_theme
/home/slinx/.frostwire4.18/themes/GTK_theme.fwtp
/home/slinx/.frostwire4.18/themes/GTK_theme/theme.txt
/home/slinx/.frostwire4.18/themes/GTK_theme/version.txt
/home/slinx/.frostwire4.18/xml/data
/home/slinx/.frostwire4.18/xml/data/audio.sxml2
/home/slinx/.frostwire4.18/xml/data/image.sxml2
/home/slinx/.frostwire4.18/xml/data/video.sxml2
/home/slinx/Download/stuff/frostwire-4.18.1.noarch.rpm
/usr/lib/frostwire
/usr/lib/frostwire/FrostWire.jar
/usr/lib/frostwire/ProgressTabs.jar
/usr/lib/frostwire/aopalliance.jar
/usr/lib/frostwire/clink.jar
/usr/lib/frostwire/commons-codec-1.3.jar
/usr/lib/frostwire/commons-logging.jar
/usr/lib/frostwire/daap.jar
/usr/lib/frostwire/forms.jar
/usr/lib/frostwire/foxtrot.jar
/usr/lib/frostwire/gettext-commons.jar
/usr/lib/frostwire/guice-1.0.jar
/usr/lib/frostwire/hashes
/usr/lib/frostwire/httpclient-4.0-alpha3.jar
/usr/lib/frostwire/httpcore-4.0-beta2.jar
/usr/lib/frostwire/httpcore-nio-4.0-beta2.jar
/usr/lib/frostwire/httpcore-niossl-4.0-alpha7.jar
/usr/lib/frostwire/icu4j.jar
/usr/lib/frostwire/jaudiotagger.jar
/usr/lib/frostwire/jcraft.jar
/usr/lib/frostwire/jdic.jar
/usr/lib/frostwire/jdic_stub.jar
/usr/lib/frostwire/jflac.jar
/usr/lib/frostwire/jl.jar
/usr/lib/frostwire/jmdns.jar
/usr/lib/frostwire/jogg.jar
/usr/lib/frostwire/jorbis.jar
/usr/lib/frostwire/junit.jar
/usr/lib/frostwire/jython.jar
/usr/lib/frostwire/log4j.jar
/usr/lib/frostwire/looks.jar
/usr/lib/frostwire/lw-all.jar
/usr/lib/frostwire/messages.jar
/usr/lib/frostwire/mp3spi.jar
/usr/lib/frostwire/onion-common.jar
/usr/lib/frostwire/onion-fec.jar
/usr/lib/frostwire/themes.jar
/usr/lib/frostwire/tritonus.jar
/usr/lib/frostwire/vorbisspi.jar
/var/lib/yum/yumdb/f/510bf1d3fec2b5e31508c8ca51680972e1180829-frostwire-4.18.1-2-noarch
/var/lib/yum/yumdb/f/510bf1d3fec2b5e31508c8ca51680972e1180829-frostwire-4.18.1-2-noarch/from_repo
/var/lib/yum/yumdb/f/510bf1d3fec2b5e31508c8ca51680972e1180829-frostwire-4.18.1-2-noarch/reason
/var/lib/yum/yumdb/f/510bf1d3fec2b5e31508c8ca51680972e1180829-frostwire-4.18.1-2-noarch/releasever

seems like kind of a lot to be left on there..

scottro
1st October 2009, 10:23 AM
I assume this is after running updatedb?

Yo should be safely able to remove the slink/.frostwire stuff.

I would think you can remove the lib stuff too, but you might want to wait till someone with more confidence sees the thread and posts on it.

Running yum clean all will possibly get rid of the stuff in /var/lib/yum, though not sure about that either.

Demz
1st October 2009, 10:30 AM
try this to updatedb
su -
password

updatedb

Slinx
1st October 2009, 10:42 AM
yeah it was after updatedb.. yeah once I get this all cleaned up I'm not installing anything like frostwire again.. thanks for helping the updatedb helps make sense out of some things now.. hopefully I can remove teh libs I think I can because they are in a frostwire folder but idk for sure.. and yum clean all doesn't take care of them for some reason..maybe I have to let yum update it first idk..

Hlingler
1st October 2009, 02:02 PM
You may safely remove the folder /home/slinx/.frostwire4.18 and all files under it.

You may safely remove folder /usr/lib/frostwire and all files under it. Clearly, these files were installed by frostwire, but somehow are not removed after the RPM was erased (this may be due to several reasons, including an aborted and/or failed erasure). Perhaps you should first try: sudo yum-complete-transaction to see if there are any unfinished transactions. If not (or if that fails to purge the files), then simply erase them.

'yum clean all' should purge the cache at /var/lib/yum/yumdb/f/... .

V

EDIT:
locate frostwire gives me this.. its after I removed it via rpm -e frostwireYou ran this as root user (or sudo or such), not as your normal user, right ?
yeah once I get this all cleaned up I'm not installing anything like frostwire again.I too would be concerned - but not too concerned - about such 3rd-party RPMs. This one (frostwire) seems to be particularly problematic, in my experience and opinion. Most others are well-behaved, as long as you don't start mixing repos, or going too far with the experiment.

Dangermouse
1st October 2009, 04:19 PM
All the files in .frostwire that was left behind is normal, for most programs when you uninstall them,
even firefox etc...(ie .mozilla) just delete that directory (.frostwire) its your user settings that
was created by you after the install not during, ie when you ran the wizard when you first started frostwire.

Slinx
2nd October 2009, 05:29 AM
Yeah thanks I will go ahead and delete the libs and I am pretty sure I ran rpm -e as root. Is there a way to have it go ahead and delete all of the contents with out having to confirm it when I do "rm -r /usr/lib/frostwire"?
Thanks danger I didn't know it was normal.

Hlingler
2nd October 2009, 05:37 AM
Please read: man rm:
sudo rm -rf /usr/lib/frostwire

Always use such 'force' options with caution, and at your own risk.

V

Slinx
2nd October 2009, 09:14 AM
alright thanks
I must have missed it in the man page some how

scottro
2nd October 2009, 11:30 AM
It's not what I would call clearly written.

This is how a Linux man page reads.



-f, --force
ignore nonexistent files, never prompt


In contrast, the FreeBSD man page


−f Attempt to remove the files without prompting for confirmation,
regardless of the file’s permissions. If the file does not
exist, do not display a diagnostic message or modify the exit
status to reflect an error. The −f option overrides any previous
-i options


A little easier to understand.

Slinx
3rd October 2009, 09:48 AM
Yeah, that is a little easier to understand. Thanks for helping me get rid of those files.

Demz
3rd October 2009, 09:53 AM
as scottro has shown above, use the force command at your own risk

scottro
3rd October 2009, 11:10 AM
Just in general, the BSD man pages, especially OpenBSD, and available at their website, are often, though of course, not always, clearer than the Linux man pages. In some cases, there will be differences--for example, the BSD ifconfig man pages explain putting an alias on an interface, but the technique is quite different than it is in Linux, and wouldn't work.