PDA

View Full Version : Sound low again after second kernel update; how to manualy remove one kernel



Diomedea
30th September 2009, 04:36 PM
Ok, what is going on? :confused: This is the second kernel that breaks the sound in Fedora 11. :eek:
Now, from the 3 kernels that Fedora keeps, only by using the last one can I have normal sound in Fedora. If the next kernel doesn't solve the problem with PulseAudio, I will be left with low sound after the next update.
So can anyone please tell me if there is a way to fix the PulseAudio problem or, if not, how to manually remove the second kernel in the Grub list so that I can keep the last one (that offers normal sound) after the next kernel update.

Sagitter
30th September 2009, 04:41 PM
Ok, what is going on? http://forums.fedoraforum.org/forum/images/smilies/confused.gif This is the second kernel that breaks the sound in Fedora 11

Which type of problem do you have with audio?

Diomedea
30th September 2009, 04:51 PM
The sound is very low, even if everything is set to maximum (the stuff in Advanced Volume Control too)

Sagitter
30th September 2009, 04:57 PM
Control audio channel with alsamixer:


$ alsamixer -D hw:0

Diomedea
30th September 2009, 05:09 PM
Tried. Everything set to maximum. Still very low sound.

Diomedea
1st October 2009, 11:51 AM
Well it seems that nobody has a solution so I removed the second kernel the way described here: http://forums.fedoraforum.org/showthread.php?t=17930

Sagitter
1st October 2009, 12:00 PM
Still very low sound.

Remain valid for all type of sound?
mp3, system sound, ogg file, ...

Astrals
1st October 2009, 12:46 PM
This also happened to one of my systems.

The answer was really simple to fix after allot of exploration.
In my case this happened with realtek hd audio.
In advanced audio under preferences i had to select VIA DXS for playback, which uses Alsa mixer.
REBOOT.
This fixed the very quiet sound issue for me.

Diomedea
1st October 2009, 02:30 PM
Thank you Astrals! That worked.

So: System> Preferences> Hardware> Advanced Volume Control> Preferences> Select "VIA DXS" and then set the slider that appears to the desired level (I set it to maximum).

Still, how was I supposed to know that? I made a kernel update and then I lost sound.

I'll check to see if when using the older kernel the VIA DXS is set to maximum. If that is the case, that's a bad mark for the Fedora guys.

Diomedea
1st October 2009, 02:57 PM
Well that was the case. When using the older kernel, the VIA DXS is set to maximum, although it's invisible (not selected in the Preferences list). But when using the latest kernel it's set to minimum by default and it's also invisible :eek:. So bad mark for the guys at Fedora.

I had similar problem when I upgraded from F10 to F11. After the upgrade I was left with no sound and also "Advanced Volume Control" didn't appear in any of the menus. I had to search the internet and found the solution with running "alsamixer -c0" in the terminal, to see that PCM was set to minimum by default :eek:. Later I found the "gst-mixer" package with yumex and installed it, this way I got "Advanced Volume Control" in System> Preferences> Hardware.