PDA

View Full Version : Problem in installation of totem 2.28 from the source.



wu_qso
26th September 2009, 03:39 AM
I downloaded the source file of the latest version of totem 2.28 and tried to install it on my F10 system. The installation needs "./configure; make; make install". When configuring, everything is ok at the beginning. But there is an error at the end:


No package 'gstreamer-plugins-base-0.10' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MISSING_PLUGINS_CFLAGS
and MISSING_PLUGINS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I have the package "gstreamer-plugins-base-0.10.21-2.fc10.i386" installed. Why the configuration still need it? What shall I do? Anybody can help me?

Hlingler
26th September 2009, 04:00 AM
Yes, but what you really need is package gstreamer-devel:
sudo yum install gstreamer-devel

Then try again....

V

P.S. Anytime you get such messages ("...No package 'gstreamer-plugins-base-0.10' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix."), you're almost certainly missing one or more *-devel packages, so start looking for likely culprits.

wu_qso
26th September 2009, 04:43 AM
Yes, but what you really need is package gstreamer-devel:
sudo yum install gstreamer-devel

Then try again....

V

P.S. Anytime you get such messages ("...No package 'gstreamer-plugins-base-0.10' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix."), you're almost certainly missing one or more *-devel packages, so start looking for likely culprits.


Thank you for your reply. The configuration of totem2.28 actually requires "gstreamer-plugins-base-devel". But after I installed this package, new error appeared.


checking for GST... configure: error: Package requirements (gstreamer-0.10 >= 0.10.24 gstreamer-base-0.10 >= 0.10.24 gstreamer-plugins-base-0.10 >= 0.10.24 gstreamer-tag-0.10 >= 0.10.24 gconf-2.0) were not met:

Requested 'gstreamer-0.10 >= 0.10.24' but version of GStreamer is 0.10.21
Requested 'gstreamer-base-0.10 >= 0.10.24' but version of GStreamer base classes is 0.10.21
Requested 'gstreamer-plugins-base-0.10 >= 0.10.24' but version of GStreamer Base Plugins Libraries is 0.10.21
Requested 'gstreamer-tag-0.10 >= 0.10.24' but version of GStreamer Tag Library is 0.10.21

The README file in the tarball file of totem2.28 only claims requirement of gstreamer 0.10.6 and gstreamer-plugins-base 0.10.7. That's really a strange question.

Hlingler
26th September 2009, 05:17 AM
In this case, you will first have to manually upgrade all gstreamer* to at least version 0.10.24. I would suggest that you fetch the F11 or F12 SRPMs and try a re-build against F10: http://koji.fedoraproject.org/koji/packageinfo?packageID=575

V

P.S. Totem sucks - why not try one of the many more feature-filled A/V players, like: VLC, Xine, MPlayer, etc.