PDA

View Full Version : Fedora 11 won't boot without monitor connected



Loter
25th September 2009, 07:55 AM
Hello,

My Fedora 11 won't boot without monitor connected, I'm not sure how could I check what's happening. When the monitor is connected, the system boots fine. When I disconnect the monitor and reboot system hangs, when I connect monitor, no signal comes.
I already tried to switch from graphical to text mode, still no luck.

Does anybody has any hints to solve this problem?

Thank you.

giulix
25th September 2009, 08:18 AM
As root, open file /etc/inittab with a text editor, and change the line


id:5:initdefault:

to


id:3:initdefault:

and reboot. If that does not work, have a look at the system log files, /var/log/messages and /var/log/dmesg. Look for the failed attempt and post here the relevant section (or just attach the entire files)

Loter
25th September 2009, 08:39 AM
Erm.. I was wrong.
It's booting.. but when I boot it without monitor connected, then connect monitor, nothing shows up(monitor tells that there's no signal)..

Any hints how to make this working ?

beaker_
25th September 2009, 11:47 AM
Try adding nomodeset to grub and booting to runlevel 3.

JohnnyAppleseed
18th October 2009, 05:57 AM
Hello,

I've been trying to figure this out myself also because I want to setup a server as well. Thanks for the suggestions but none worked for me till I tried this link
http://www.linux.org/docs/ldp/howto/Remote-Serial-Console-HOWTO/configure-kernel.html

I added to the kernel line "console=ttyS0,9600n8" to make the system print out to the console line port.
In any case, I can now safely boot without a monitor, but if I connect it again I can interact again with my PC again like before.

I'm using grub so here is my file so you can see where you need to add the argument
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/mapper/vg_repository-lv_root
# initrd /initrd-version.img
#boot=/dev/sda
#splashimage=(hd0,0)/grub/splash.xpm.gz
#hiddenmenu
default=0
timeout=0
title Fedora (2.6.30.8-64.fc11.i686.PAE)
root (hd0,0)
kernel /vmlinuz-2.6.30.8-64.fc11.i686.PAE ro root=/dev/mapper/vg_repository-lv_root rhgb quiet console=ttyS0,9600n8
initrd /initrd-2.6.30.8-64.fc11.i686.PAE.img
~

JohnnyAppleseed
18th October 2009, 11:26 PM
scratch the above solution, doesn't work long term. So Fedora will boot just fine without a monitor attached, but after a little while (30 min tops) it hangs/crashes.

I'm a linux newbie, where can I check relevant log/message concerning this crash/hang ?

jpollard
18th October 2009, 11:44 PM
You will have to include the boot logs to get any more information.

In my case, I run the system without a monitor, but when I connect it, it works fine - though the blanking timeout
can be a bit surprising at first.

Have you enabled ssh, and tried to login over the net?

The usual reason for a problem is not the monitor, but the keyboard. If the BIOS is configured to operate without
a keyboard, then the system should function normally.

JohnnyAppleseed
19th October 2009, 02:22 AM
I have my my BIOS settings for "Report Keyboard Errors" to Do Not Report, and it still crashes/hangs... Is there a log I can check that says why it crashed hanged?

jpollard are you using the serial port as your console value on the kernel line like me or are you doing something different?

jpollard
19th October 2009, 12:23 PM
The only logs I know of would be the /var/log/messages.

No, I'm not using a serial port - that usually requires a serial connection to another device (dumb terminal/or other system). I'm not sure it's even required. I do take the monitor for other purposes (I have it connected to a TV/video
converter in another room).