View Full Version : X/KDE instability

15th September 2009, 12:34 AM
For a long time now, my desktop has been very unstable. Of course, that's normal for Rawhide.

But as things have moved along, this instability has improved but not gone away.

The symptoms are that the desktop just locks up. Mouse doesn't move, keyboard doesn't work (not even caps-lock). I can't switch VTs.

On some occasions, the whole machine locks up. In that case a reset is required.

On other occasions, the desktop has locked up, but the o/s is still running. In fact, if I was listening to music with Amarok, the music often keeps playing. In this case, a soft-reset (pressing the power button, and letting the o/s shutdown gracefully) is the only recovery option I have found.

It is not entirely obvious when these things occur. But it seems more likely if I am playing music. And it tends to happen when starting or stopping applications.

Now, I thought it might be a hardware fault, but I have replaced various parts, tested RAM etc, with no issues. And Windows XP runs fine.

Am I alone in experiencing this?

15th September 2009, 08:03 PM
Are you running Firefox when this happens?

16th September 2009, 12:06 AM
Yes, I'm always running firefox (for mail).

But, the frequency/likelihood tends to increase dramatically if I do anything that makes the system busy. In particular, playing audio through amarok seems a good way to increase the chances of a crash.

Also, if I login with a failsafe session (no wm) and run metacity ... the frequency of crashes is less to maybe none (I haven't had to do this in a while, so I'm not 100% sure).

17th September 2009, 08:42 PM
Nest time this happens try ssh'ing in from another computer and killing of Firefox and see if it goes away instantly. If it does you have your culprit.

Leaving the desktop frozen is a common "feature" of Firefox when it is having problems downloading some thing. Usually what it is having problems downloading is advertising. There is lots of work going on to fix the problem. The two most prominent ones are no longer running X as root and a coming rewrite to make every tab a separate process in Firefox.

23rd September 2009, 12:46 AM
Nothing to do with firefox ... X server seg faults causing all X clients to die (including firefox).

I reported the problem here: https://bugzilla.redhat.com/show_bug.cgi?id=523905. It was reported a week ago, and nobody has even triaged the bug. So I'm guessing they have no more resources to deal with this.

29th October 2009, 12:08 PM
I have a AMILO 4700 2GB, Laptop
Intel 855GM Chipsatz, 64 MB Shared Memory
Every kernel

which worked fine under F10 and XP.
Now I get random X crashes under Gnome, KDE and XFCE.
And CPUload is 100% .........

If I'm doing nothing, X runs. When I open up some windows,
it ocassionally crashes.

Other processes work fine, can ssh the machine.
The mouse is moveable.
Cannot change with ctrl-alt f to a console.

Tried the nolapic and vga=normal.

Added a Xorg.conf via system-config-display

Still the same.

Any idea ?


29th October 2009, 09:59 PM
You have a completely different graphics chipset, from a completely different manufacturer; this isn't likely to be the same bug.

I can see some useful error messages in /var/log/messages which look like they're what's going wrong for you. One set of them runs from:

Oct 25 13:15:59 fettora kernel: INFO: task i915/0:111 blocked for more than 120 seconds.


Oct 25 13:35:59 fettora kernel: #2: (&dev->struct_mutex){+.+.+.}, at: [<f7d9d9fc>] i915_gem_retire_work_handler+0x34/0x81 [i915]

and there's two further sets of similar messages. I'm betting those times would match with when you saw the bug, right?

Could you file a new bug on the kernel, with a description of the symptoms, the output of 'lspci -v' , and your /var/log/messages attached? Let me know the URL when you're done and I will triage it appropriately.

30th October 2009, 10:57 AM

I filed a bug !


5th November 2009, 02:29 AM
Problems *seem* resolved by X server v1.7.1 (1.7.1-6 tested)

9th November 2009, 02:32 AM
I can confirm this bug. Your solution is to try to downgrade to kernel if you can. That works and it is pre the intel-linux-next kernel driver push the intel guys made to mainline even after I politely asked them not to because what they made available for test was even worse.
You may experience the odd slight freeze but nowhere near the absolutely guaranteed freezing exhibited by kernels greater than
I also have an intel 855GM graphics chip and right now no Linux distribution that uses a kernel version greater than will allow you to use xorg without freezing almost straight after login.
So I do not think that fedora 12 will not support intel 855GM chipsets.
(A group of us have been reporting it getting worse and worse to developers over the last six months, with the latest updates having completely broken the i915 driver with 855GM hardware. They don't seem to care.)

10th November 2009, 08:08 AM
Hi Zanpactou,
"So I do not think that fedora 12 will not support intel 855GM
Do you mean that Fedora 12 will support intel 855GM chipsets? And if the kernel upgrade happens in Fedora 12, is it likely to break the graphics. Is there any bug filed in bug tracking database that can be tracked by others?


10th November 2009, 08:23 AM
narasim_7: please follow https://bugzilla.redhat.com/show_bug.cgi?id=531111 .