PDA

View Full Version : No screensaver in xfce4



jim1944
6th September 2009, 03:41 AM
I'm using xfce4 in F11. If a walk away from the computer for hours, the screensaver doesn't come on, locking up the computer. In F10 with the previous version of xfce, it did lock up the computer after a few minutes of inactivity. I can't find any setting in xfce4 to set the time out. What's going on?

Thanks
Jim

stoat
7th September 2009, 06:40 PM
Hello jim1944,

For me and F11 and XFCE, the screensaver applet is still in Preferences. Maybe it would be helpful to see what is installed (rpm -qa | grep screensaver).

jim1944
7th September 2009, 10:21 PM
$ rpm -qa | grep screensaver
gnome-screensaver-2.26.1-3.fc11.i586
fedora-screensaver-theme-1.0.0-4.fc11.noarch
fedorainfinity-screensaver-theme-1.0.0-2.fc11.noarch

I found the screeensaver preferences and they are set properly;
1. Regard computer as idle after 5 mins.
2. Activate screensaver when idle - checked
3. Lock screen when screensaver is active - checked

Screensaver does not active after hours and the screen does not lock.

jim

stoat
7th September 2009, 10:52 PM
Okay. I don't know if it matters or not. Will help or not. But I have been using XFCE exclusively since Fedora 8. I have always installed xscreensaver (yum install xscreensaver). I have what you have there, too. It gets pulled in by something I install. Anyway, FWIW. Maybe nothing. You decide.
$ rpm -qa | grep screensaver
xscreensaver-extras-5.08-13.fc11.i586
xscreensaver-gl-extras-5.08-13.fc11.i586
xscreensaver-base-5.08-13.fc11.i586
xscreensaver-5.08-13.fc11.i586
fedorainfinity-screensaver-theme-1.0.0-2.fc11.noarch
xscreensaver-gl-base-5.08-13.fc11.i586
gnome-screensaver-2.26.1-3.fc11.i586
fedora-screensaver-theme-1.0.0-4.fc11.noarch

jim1944
8th September 2009, 03:09 AM
"yum install xscreensaver" made the difference after killing gnome-screensaver daemon, starting xscreensaver daemon and restarting.

For whatever reason gnome-screensaver isn't doing the job for xfce. On the rare occasions when I use gnome desktop it does lock up. I started using mostly xfce in F7 and had no such issue but I upgraded to F8, F9 and F10. Then upgrade failed for F11, forcing a full install. That's when xfce started not locking up after being idle. I did not keep good track of what I had installed so I don't know what screensaver daemon I was using previously.

Thanks Jim

stoat
8th September 2009, 03:15 AM
So I wonder if I can remove the gnome-screensaver stuff. I don't use Gnome and don't intentionally install anything with gnome in its name. So something I do install must need it. I might check what depends upon it and consider it. I have two "Screensaver" menu entries in "Preferences" which is probably related to that, too. One of them doesn't seem to be functional. Probably what you had originally, I guess.

stoat
8th September 2009, 03:40 AM
The gnome-screensaver package is required by f-spot which I did install and need...
Package to query: gnome-screensaver

REQUIRED BY

fedora-screensaver-theme-1.0.0-4.fc11.noarch
fedorainfinity-screensaver-theme-1.0.0-2.fc11.noarch
f-spot-0.6.0.0-1.fc11.i586

Done.So there I have it. Keeping it, I guess. BTW, an rpm query yielded a ton of gnome-* stuff.

jim1944
9th September 2009, 02:58 AM
So I wonder if I can remove the gnome-screensaver stuff. I don't use Gnome and don't intentionally install anything with gnome in its name. So something I do install must need it. I might check what depends upon it and consider it. I have two "Screensaver" menu entries in "Preferences" which is probably related to that, too. One of them doesn't seem to be functional. Probably what you had originally, I guess.
I had one screensaveer entry until I installed Xscreensaver. Now I also have two.

I get the same "required by" for gnome-screensaver.

Jim

stoat
9th September 2009, 06:25 PM
I use the xscreensaver applet. I can't remove the Gnome screensaver applet since I use f-spot which installed it. But it can be hidden in the XFCE menu. Copy (not move or delete) its launcher from /usr/share/applications to ~/.local/share/applications in your home directory.

Open the copy of the launcher in ~/.local/share/applications for editing and add this line...
NoDisplay=true