PDA

View Full Version : Recover GNOME keyring



joe.pelayo
5th September 2009, 09:15 AM
Hello everybody.

For several weeks now I have been experiencing a problem with GNOME keyrings in Fedora 10 x86. Here is the thing: somehow out of the sudden GNOME started requesting the "Default Keyring" in order to connect to protected wireless networks it already knows. I don't remember having set one, maybe I did, and just in case I tried all my passwords to no avail.

On the other hand, XFCE, the desktop environment I use the most in that machine, has lost its ability to 'remember' passwords, which is a little painful in the long run.

I wouldn't want to just delete the keyrings because there are many stored already, and I want them back. Needless to say I have root access to the machine. Is it possible somehow as root (or as user) to fix that problem and restore both access to the stored passwords and the ability for Network Manager to remember them?

Just to be on the safe side I created another user and that one 'remembers' the stored passwords and is not prompted for the "Default Keyring".

Thanks,
Joe.

Dangermouse
5th September 2009, 09:22 AM
Hi Joe,

if you didnt set a password then it should be your login password, i have found i only get this behaviour when i use autologin, or timelogin etc. if you disable that and login with a pasword the keyring is automaticly unlocked, guess its a security feature or something.

Dave

joe.pelayo
5th September 2009, 10:01 AM
Hi Joe,

if you didnt set a password then it should be your login password, i have found i only get this behaviour when i use autologin, or timelogin etc. if you disable that and login with a pasword the keyring is automaticly unlocked, guess its a security feature or something.

Dave
Hi Dave,

I'll try enabling and disabling automatic access (which is currently disabled). On the other hand I've tried every possible password I might have set (including the login) and it does not unlock.

Thanks,
Joe.

Iron_Mike
5th September 2009, 10:34 AM
The "keyrings" might be corrupted and the only way to fix them might be to delete them and start over with new keyrings.

JEO
5th September 2009, 02:20 PM
On Fedora 10, if you mistype your password it will create a file called login.keyring in /home/<username/.gnome2/keyrings directory. The file named default.keyring is then no longer automatically used. The cure is to rename or delete the login.keyring every time this happens, and logout of gnome and login again, and it will go back to using default.keyring file.