PDA

View Full Version : Mounting NTFS Partitions in F11



BobLfoot
3rd September 2009, 11:02 PM
I've got a Desktop System that Automounted Two NTFS partitions in F10 so I could declare them SAMBA Shares and have my other XP and Vista Machine Access them whether my dual boot machine ran XP or F10. Now I've switched to F11 and cannot get the NTFS Partitions to Automount at boot.

If I browse with COMPUTER and let the system mount the NTFS partitions once it is running the mount command returns the following output:



[root@COMP100 Bob]# mount
/dev/sdc7 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw)
/dev/sdc6 on /boot type ext3 (rw)
/dev/sdc8 on /home type ext4 (rw)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
gvfs-fuse-daemon on /home/Bob/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=Bob)
/dev/sda5 on /media/Comp 100 Extra Data type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,b lksize=4096)
/dev/sdc5 on /media/Comp 100 Second Drive type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,b lksize=4096)
[root@COMP100 Bob]#


The fdisk output is as follows:


[root@COMP100 Bob]# fdisk -l /dev/sda

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x35133512

Device Boot Start End Blocks Id System
/dev/sda1 * 1 16708 134206978+ 7 HPFS/NTFS
/dev/sda2 16709 24321 61151422+ f W95 Ext'd (LBA)
/dev/sda5 16709 24321 61151391 7 HPFS/NTFS
[root@COMP100 Bob]# fdisk -l /dev/sdc

Disk /dev/sdc: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xfc7c95b4

Device Boot Start End Blocks Id System
/dev/sdc1 * 2 38913 312560640 f W95 Ext'd (LBA)
/dev/sdc5 22442 38913 132311308+ 7 HPFS/NTFS
/dev/sdc6 2 50 393529+ 83 Linux
/dev/sdc7 51 15913 127419516 83 Linux
/dev/sdc8 15914 22441 52436128+ 83 Linux

Partition table entries are not in disk order
[root@COMP100 Bob]#


I believe I need to modify /etc/fstab but cannot get the syntax correct to save my life. Any Help is much appreciated.

BobLfoot
3rd September 2009, 11:53 PM
Hours of playing to get it correct. Post the question here and the next thing I tried fixed it.

I installed the ntfs-config package and used it to configure the sda5 and sdc5 partitions.

After that Samba works even before I log in on the local box once booted.

It's great.

One loss - gnome would let a user mount the ntfs with computer prior to using config.

Now I must be root to mount and umount -- I think because they are in /etc/fstab.

BTW here is the new /etc/fstab



[Bob@COMP100 Documents]$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts defaults 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
#Entry for /dev/sdc7 :
UUID=55e249d4-48f4-4928-b4e5-0c905002c8a3 / ext4 defaults 11
#Entry for /dev/sdc6 :
UUID=c18e3698-a35d-404e-9f44-27999ebf2fdf /boot ext3 defaults 12
#Entry for /dev/sdc8 :
UUID=52effc4c-a2ee-479d-82e5-2562448d17db /home ext4 defaults 12
#Entry for /dev/sda5 :
UUID=5024273B24272406 /media/Comp\040100\040Extra\040Data ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8 0 0
#Entry for /dev/sdc5 :
UUID=24C45DE8C45DBD2C /media/Comp\040100\040Second\040Drive ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8 0 0
#Entry for /dev/sdb2 :
UUID=6ce1e9d7-404a-4c7e-b417-217dd0b232a7 swap swap defaults 00


[Bob@COMP100 Documents]$