PDA

View Full Version : KQEMU no longer support kernel full virtualization?



aleph
26th August 2009, 04:29 AM
I wiped away the dust on my virtual machine images and decided to give them a go. Installed QEMU and KQEMU accelerator (from RPMFusion), got the KQEMU module loaded, only to find the option "-kernel-kqemu" (see http://www.nongnu.org/qemu/kqemu-doc.html#SEC6) no longer recognized. When I was on F10 it used to work, and I can't find any reference to this in the RPM changelogs.

Any ideas?

P.S. The CPU's an old Pentium M (32-bit) with no KVM support. The Linux kernel is an i686 PAE one. Could PAE be the problem here?

TarrasQ
29th August 2009, 07:36 PM
I bumped into the same issue yesterday and finally found VirtualBox satisfying.

Gödel
29th August 2009, 09:46 PM
The fedora version of qemu isn't compiled with kqemu support anymore, apparently they consider it obsolete technology, (qemu-kvm is a much faster alternative if supported). There may be alternative rpms around, or you can just download the latest source and compile it yourself (You can then just install kqemu from rpmfusion)

http://www.qemu.org/download.html

Since you don't need kvm support do,



./configure --disable-kvm
make -j2
sudo make install

by default the binary is installed to /usr/local/bin/qemu

eg


sudo modprobe kqemu
sudo /usr/local/bin/qemu -m 512 /dev/sdb &

Use qemu monitor to check if kqemu is running, ctrl+alt+2 switches the qemu session to monitor, then type 'info kqemu' it should say

"kqemu support: enabled for user and kernel code"

(ctrl+alt+1 switches back to the qemu session)

aleph
30th August 2009, 04:37 AM
Well, if the kqemu feature is no longer blessed by the official build, I'll have to recompile my own RPMs then, since I'm going to stick with the "obsolete technology" for quite a long time.

Thank you guys.