PDA

View Full Version : Apache not available via internet



ThorMoD
25th August 2009, 09:40 PM
Thanks in advance:

Problem: I have a working apache server running on my local lan. If anyone NOT on my lan tried to access my server, it will not show up.

What I have found:
The apache test page is visible on the fedora server.
The apache test page is visible on all of my computers on the lan
The apache test page is visible by entering the local IP address of the server
The apache test page is visible by entering my 'outside' ip address
The apache test page is visible by entering the domain name I have directed to this server.
All of the above ONLY works on my lan. If I use my computer from work, no dice. If I use my iPhone while the lan card is disabled, no dice. As soon as I enable the lan on the iPhone, boom it works...

What I have tried so far:

I physically removed the router and directly connected the server to the modem.
I turned the fedora firewall off, to see if it was blocking me.
I HAVE enable the ports on the firewall. 80
The router is set to forward the port 80 requests to the static ip of the fedora server.

What is wierd:
HTML requests are not resolving.
Another port 8080 is working, I use this for subsonic and its perfect.
I also have hosted a TeamSpeak server on this box via another port, it works too...


HELP!

Thor

ThorMoD
25th August 2009, 09:45 PM
I enabled Masquerading for the ethernet card and thought it worked, it didnt.

EnglandA
25th August 2009, 11:09 PM
In your httpd.conf, what is your "Listen" line set to? Alternatively, run a netstat -tapn|grep httpd and see what IP your httpd is listening on.

ThorMoD
25th August 2009, 11:30 PM
[root@localhost FlukE]# netstat -tapn|grep httpd
tcp 0 0 :::80 :::* LISTEN 6793/httpd
tcp 0 0 :::443 :::* LISTEN 6793/httpd


Listen 80

BTW, my SSH doesnt work either from any remote computer. so, ports 80 and 22 are not remote accessible.

Thanks

YeOK
25th August 2009, 11:50 PM
Sounds like your ISP is blocking ports. I'd check google to see if others have the same problem.