PDA

View Full Version : Unable to boot



Mcjugga
24th August 2009, 05:53 PM
Since last night, I have been unable to boot Fedora 11. I am not sure what caused it, but I am pretty sure that it was caused by some sort of update.

When I try to boot, it gets past the screen with the 3 loading bars, then just goes to some black screen where it should have gone to the login screen.

I looked in the logs and saw some stuff about the Nvidia driver messing up or something like that, so I tried to get a newer driver, in case that would fix the problem.

I went to the Nvidia website and saw that there was a new driver, 185.18.36, that came out a few days ago. So I got that and tried to install it, but it says "unable to find kernel source tree for currently running kernel"

So I tried to get the kernel source, but it says I already have the latest version...


What should I do next?

mrwill
24th August 2009, 08:16 PM
are you sure that the version of your kernel, and the kernel source you have installed are the same?!
you can find the kernel version with the following command:

uname -r

anyway this can be a bug of nvidia driver. if the problem persists try uninstalling the driver but i don't think that nvidia driver is the cause of your problem.
when booting up press the escape button for the text mode instead of the graphical mode and see if you can find any errors.

kulbirsaini
24th August 2009, 08:46 PM
I think you are missing the 'kernel-devel' package for the kernel you have. Try installing that and then install the drivers.

Mcjugga
24th August 2009, 09:08 PM
I think you are missing the 'kernel-devel' package for the kernel you have. Try installing that and then install the drivers.

I typed
yum install kernel-devel and it said that I already have the latest version installed.

kulbirsaini
24th August 2009, 10:08 PM
What is the output of "ls /lib/modules/`uname -r`"? If nothing is displayed you don't have kernel-devel for the kernel you have booted in.

Alternate : You can try using kmod-nvidia package from rpmfusion. It takes care of nvidia drivers even when you update kernels :)

Mcjugga
25th August 2009, 04:40 AM
What is the output of "ls /lib/modules/`uname -r`"? If nothing is displayed you don't have kernel-devel for the kernel you have booted in.

Alternate : You can try using kmod-nvidia package from rpmfusion. It takes care of nvidia drivers even when you update kernels :)

The output is
Cannot access lib/modules/2.6.29.4-167.fc11.x86_64: No such file or directory.

I tried to install the kmod-nvidia package, but I had the same problem.

I have an nvidia 8500gt, by the way.

mrwill
25th August 2009, 11:16 AM
The output is
Cannot access lib/modules/2.6.29.4-167.fc11.x86_64: No such file or directory.

be sure you have installed the following packages:


yum install kernel
yum install kernel-devel
yum install kernel-headers

then if possible please post the output of the following commands:

uname -a
rpm -qa | grep kernel
ls -l /lib/modules/$(uname -r)

fpmurphy
25th August 2009, 04:19 PM
I am not sure what caused it, but I am pretty sure that it was caused by some sort of update.
Probably caused by an update of the kernel. You can check the /var/log/yum to confirm.

Every time the kernel is updated you need to load a new version of the nvidia driver. However that driver is often not available in the repos for a few days after the release of the new kernel.

Falconus
25th August 2009, 04:30 PM
Ah, it sounds like you may have the same problem that I had repeatedly. It was a very simple fix. Everytime you update the kernel, you have to reinstall your nvidia driver, if it doesn't update automatically. You can get it so it updates automatically (I think through rpm-fusion nonfree or something like that), or you can install it manually. To do it manually, get the nvidia driver off of nvidia's website, and run it in runlevel three. You must have kernel-devel installed before you do that. To boot into runlevel three (which should work regardless of the error you are having), press any key when prompted, and type "a" when you have selected the appropriate kernel. Append a three to the end of the command. That should work, if it's the same problem I was having. If I confused you, let me know, and I'll clarify.

Mcjugga
25th August 2009, 05:25 PM
be sure you have installed the following packages:


yum install kernel
yum install kernel-devel
yum install kernel-headers

then if possible please post the output of the following commands:

uname -a
rpm -qa | grep kernel
ls -l /lib/modules/$(uname -r)


I have kernel, kernel-devel and kernel-headers installed to the latest version.

Here are the outputs of the commands:

uname -a

Linux localhost.localdomain 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa | grep kernel

kernel-2.6.29.6-217.2.3.fc11.x86_64
kernel-devel-2.6.29.6-217.2.7.fc11.x86_64
kernel-headers-2.6.29.6-217.2.8.fc11.x86_64
kerneloops-0.12-5.fc11.x86_64
kernel-2.6.29.6-217.2.8.fc11.x86_64
kernel-devel-2.6.29.6-217.2.3.fc11.x86_64
kernel-firmware-2.6.29.6-217.2.8.fc11.noarch
kernel-devel-2.6.29.6-217.2.8.fc11.x86_64
kernel-2.6.29.6-217.2.7.fc11.x86_64

ls -l /lib/modules/$(uname -r)

total 4
drwxr-xr-x.2 root root 4096 2009-08-24 12:38 video

Mcjugga
25th August 2009, 05:49 PM
Ah, it sounds like you may have the same problem that I had repeatedly. It was a very simple fix. Everytime you update the kernel, you have to reinstall your nvidia driver, if it doesn't update automatically. You can get it so it updates automatically (I think through rpm-fusion nonfree or something like that), or you can install it manually. To do it manually, get the nvidia driver off of nvidia's website, and run it in runlevel three. You must have kernel-devel installed before you do that. To boot into runlevel three (which should work regardless of the error you are having), press any key when prompted, and type "a" when you have selected the appropriate kernel. Append a three to the end of the command. That should work, if it's the same problem I was having. If I confused you, let me know, and I'll clarify.
When exactly should I see this prompting?

Mcjugga
25th August 2009, 09:27 PM
Ok, I think I know the problem...
I have the new kernel on my computer, and this is why when I type "yum install kernel" it says I have the latest version, same goes for kernel-devel.
However, I can't install the nvidia driver because the kernel that my computer is running is the old version, since I am running off of the CD. I have the new kernel, I am just not running it.

So what I need to do, as Falconus has said, is boot without the CD, but boot in runlevel 3 so that X is disabled.

When I try to figure out how to do this, I am told to press "a" instead of enter at the grub screen (where you choose your operating system) and then add a "3" to this line "kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ acpi=on rhgb quiet".
However, I can't do this since I don't have that grub screen... I only have one OS and therefore it just automatically boots to Fedora 11.


So all I need to know is how to boot in runlevel 3 given my circumstance and I think I should be able to fix my problem.

mrwill
25th August 2009, 10:08 PM
i see that the version of kernel shown in the "rpm -qa" is different from the kernel in "uname -r".
in order to fix it you should change the /boot/grub/menu.lst file to use the correct kernel.

take a look at this file and try to change the vmlinuz version to the correct version (I think: 2.6.29.6-217.2.8.fc11.x86_64)
i hope this will fix your problem!

Falconus
26th August 2009, 04:06 AM
Sometimes I have had grub set to wait almost no time to start up. When you get your computer working, open the terminal, become the superuser, and edit the file /etc/grub.conf. Where it says "timeout=0" (or whatever number is there), replace the number with the number of seconds you wish it to wait for you in startup (I'm using 10).

su -c 'vi /etc/grub.conf'
Hit insert to change data, and use your keyboard. After that hit SHIFT+Q. If after you hit SHIFT+Q it says "RECORDING" hit SHIFT+Q again. Then type 'w' to save changes and 'q' to quit.

Now I know that doesn't help you yet; you still have to figure out how to log in to change that. What I did when I had the display problem was turn the power button on and hit the space bar repeatedly until it got to the screen to select kernels. Then you can select the kernel you want, press a, and boot in runlevel three as stated above. Just keep an eye on the screen in case the space bar does something else in your computer (on mine it does absolutely nothing until it gets to grub).

Let me know if that doesn't work, and I'll try to think up something else.

Mcjugga
26th August 2009, 09:10 PM
Ok, I was able to boot in runlevel 3 by editing the /etc/inittab file.

I then restarted and booted in runlevel 3. There, I was able to install the new Nvidia driver (185.18.36). I then edited the inittab file again to make it boot in runlevel 5. Then I restarted, and after the 3 bars loaded, it no longer crashes. However, the login screen doesn't appear either.
It just displays some text saying that eth0 link is not ready, or something like that...
Anyways, I can press ctrl+alt+f2, log in to root and do stuff there.
So I guess installing that nvidia driver somewhat fixed my problem, but it still isn't quite working.


@mrwill: The reason the version of kernel shown in the "rpm -qa" was different from the kernel in "uname -r" is that I was booting using the rescue feature in the fedora CD, which has an older kernel.
When I booted without the CD, and ran the commands, they were both the same.

How should I proceed?

Mcjugga
28th August 2009, 12:22 AM
Alright, I fixed my problem by installing some open source Nvidia driver. However, I can't play any games without experiencing major lag.
I guess all I can do for now is wait for the next Nvidia driver to come out.


One more thing, can someone explain to me what exactly akmod-nvidia is and what kmod-nvidia is?
Thanks you.

moxie
28th August 2009, 07:57 PM
so, here's what I did to fix it. I had the same problem with the kernel updates as well. It wouldn't boot, there was just a blinking cursor on the top of the screen.

So, In the grub menu, I modified the arguments for booting into the kernel. I added 3 to boot with no x, command prompt only. Then at the command prompt, I deleted /etc/X11/xorg.conf

rebooted and everything works great.

hope that helps somebody

Mcjugga
31st August 2009, 02:16 AM
I was wondering if anyone knows if installing this would possibly work:
http://www.nvnews.net/vbulletin/showthread.php?p=2071551

It is the current Nvidia linux beta driver release.


Also, how would I go about installing it since it has 3 run files?

Falconus
31st August 2009, 08:58 PM
I know that I have used just the nvidia drivers from nvidia.com and what I got from rpmfusion nonfree. The driver that I got from nvidia.com required installation in runlevel three; the rpmfusion did not. Both worked very well.

Also, the major lag is probably being caused by a lack of a 3D accelerator, which is what I installed from nvidia.com and rpmfusion nonfree (not at the same time), as I already had drivers for the graphics card. You may want to see if you can get that to work.