PDA

View Full Version : Autologin fails with GDM.



mightymike2
24th August 2009, 09:54 AM
Hi all,

i'm new here this is my fist post,
my question is regarding Autologin with gnome.

i'm running fedora 10 Gnome ver 2.24.3 kernel 2.6.30.4

i tried to change my /etc/gdm/custom.conf by adding it the following lines:
[daemon]
TimedLoginEnable=true
TimedLogin=your_mike
TimedLoginDelay=0

after reloading gnome it's trying to log through "autologin" but than it give an error message
"Unable to authenticate user", i tried using passwd -d on my account but still the error persisted,
i saw that some users had this error after a fresh install just with logging into the machine without relation to autologin and they needed to change their password first i tried that as well.

i also tried to edit the /etc/gdm/gdm.schemas file
<schema>
<key>daemon/AutomaticLoginEnable</key>
<signature>b</signature>
<default>true</default> <schema>
<key>daemon/AutomaticLogin</key>
<signature>s</signature>
<default>mike</default>
</schema>
</schema>

But unfortunately the results were the same, i tried this procedure on a different Fedora 7 and on a virtual ubunto 9.4 machine and is was successful.

Any suggestion?

thanks beforehand
Mike.

tunerX
24th August 2009, 01:55 PM
All I did was add this to /etc/gdm/custom.conf. It worked with F10 and F11.

[daemon]
AutomaticLoginEnable=true
AutomaticLogin=guerrieroa

Dangermouse
24th August 2009, 02:00 PM
Hi and Welcome to the forum,

i tried to change my /etc/gdm/custom.conf by adding it the following lines:
[daemon]
TimedLoginEnable=true
TimedLogin=your_mike
TimedLoginDelay=0

Are you sure you have your logname correct?

mightymike2
24th August 2009, 09:10 PM
Hi and Welcome to the forum,

Are you sure you have your logname correct?

Hi,

well i wish that it was something as simple as that :) , here is the full output of the configuration file from my prompt:
[mike@localhost ~]$ cat /etc/gdm/custom.conf
# GDM configuration storage

[xdmcp]
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=mike
[chooser]

[security]

[debug]


[mike@localhost ~]$

my original message had a typo at the username but it was not originated from the configurations file,
i just posted that from work and didn't have the original in front of me to copy.
but the one above is from the actual configurations file.

i also tried to create a brand new user from scratch just for this purpose and i still received an error "unable to authenticate user",
couldn't take a normal screen shot so i turned into a "lowtech" method, screen shot attached.

Dangermouse
24th August 2009, 10:00 PM
Here is mine

[root@localhost ~]# cat /etc/gdm/custom.conf
# GDM configuration storage

[xdmcp]

[chooser]

[security]

[debug]
[daemon]
TimedLoginEnable=true
TimedLogin=Dangermouse
TimedLoginDelay=8
[root@localhost ~]#

mightymike2
25th August 2009, 12:00 PM
Hi,
thanks for the reply i tried to change the order of the custom.conf file to be identical to yours but it didn't help, i restarted GDM it didn't have any affect.
[mike@localhost ~]$ cat /etc/gdm/custom.conf
# GDM configuration storage

[xdmcp]

[chooser]

[security]

[debug]
[daemon]
TimedLoginEnable=true
TimedLogin=mike
TimedLoginDelay=8
[mike@localhost ~]$

any ideas?

Dangermouse
25th August 2009, 12:28 PM
Strange ? im sure probably got it right but you didnt use mike with capital M or something, type logname in terminal to check its the same.....

mightymike2
25th August 2009, 12:38 PM
Hi,
here is the output:

[mike@localhost ~]$ logname
mike
[mike@localhost ~]$

mightymike2
26th August 2009, 03:09 PM
Anyone, Any suggestions?

Dangermouse
26th August 2009, 07:48 PM
I am at a loss as to what to suggest next, best i can say is check /etc/gdm/gdm.schemas is correct (bump;))
heres mine

<gdmschemafile>
<schemalist>

<schema>
<key>chooser/Multicast</key>
<signature>b</signature>
<default>false</default>
</schema>
<schema>
<key>chooser/MulticastAddr</key>
<signature>s</signature>
<default>ff02::1</default>
</schema>

<schema>
<key>daemon/User</key>
<signature>s</signature>
<default>gdm</default>
</schema>
<schema>
<key>daemon/Group</key>
<signature>s</signature>
<default>gdm</default>
</schema>
<schema>
<key>daemon/AutomaticLoginEnable</key>
<signature>b</signature>
<default>false</default>
</schema>
<schema>
<key>daemon/AutomaticLogin</key>
<signature>s</signature>
<default></default>
</schema>
<schema>
<key>daemon/TimedLoginEnable</key>
<signature>b</signature>
<default>false</default>
</schema>
<schema>
<key>daemon/TimedLogin</key>
<signature>s</signature>
<default></default>
</schema>
<schema>
<key>daemon/TimedLoginDelay</key>
<signature>i</signature>
<default>30</default>
</schema>

<schema>
<key>security/DisallowTCP</key>
<signature>b</signature>
<default>true</default>
</schema>

<schema>
<key>xdmcp/Enable</key>
<signature>b</signature>
<default>false</default>
</schema>
<schema>
<key>xdmcp/MaxPending</key>
<signature>i</signature>
<default>4</default>
</schema>
<schema>
<key>xdmcp/MaxSessions</key>
<signature>i</signature>
<default>16</default>
</schema>
<schema>
<key>xdmcp/MaxWait</key>
<signature>i</signature>
<default>30</default>
</schema>
<schema>
<key>xdmcp/DisplaysPerHost</key>
<signature>i</signature>
<default>1</default>
</schema>
<schema>
<key>xdmcp/Port</key>
<signature>i</signature>
<default>177</default>
</schema>
<schema>
<key>xdmcp/HonorIndirect</key>
<signature>b</signature>
<default>true</default>
</schema>
<schema>
<key>xdmcp/MaxWaitIndirect</key>
<signature>i</signature>
<default>30</default>
</schema>
<schema>
<key>xdmcp/PingIntervalSeconds</key>
<signature>i</signature>
<default>15</default>
</schema>
<schema>
<key>xdmcp/Willing</key>
<signature>s</signature>
<default>/etc/gdm/Xwilling</default>
</schema>
</schemalist>
</gdmschemafile>

mightymike2
30th August 2009, 11:19 PM
Hi Thanks for all the help,

unfortunately that didn't work but i found a workaround the problem.


i autologin into run level 3 by doing the following

changed my /etc/inittab to loginto run-level3

id:3:initdefault:

changed my /etc/event.d/tty1 last line to that logs my user into terminal mode

exec /sbin/mingetty --autologin mike tty1

and finally i start X added that function to my .bash_profile


if [ -z "$DISPLAY" ] && [ $(tty) = /dev/tty1 ]; then
while true
do
startx --
sleep 10
done
fi


And that works pretty smoothly for now, it still would have been nice to find out what caused the gnome login to fails,
anyhow again thanks a lot for the the time spent trying to figure the problem out i appreciate it.