PDA

View Full Version : Missing Dependencies



isinias
23rd August 2009, 05:59 PM
I was running "yum update" when I lost my internet connection. I continued with "yum --skip-broken update" when I got it back. Now when I try to finish the update I get the errors:

Error: Missing Dependency: totem = 2.26.2 is needed by package totem-gstreamer-2.26.2-1.fc11.i586 (installed)
Error: Missing Dependency: PackageKit = 0.4.6-8.fc11 is needed by package PackageKit-glib-0.4.6-8.fc11.i586 (installed)
Error: Missing Dependency: perl = 4:5.10.0-68.fc11 is needed by package 4:perl-libs-5.10.0-68.fc11.i586 (installed)
Error: Missing Dependency: perl = 4:5.10.0-68.fc11 is needed by package 3:perl-version-0.74-68.fc11.i586 (installed)

How do I install those missing dependencies?

kulbirsaini
23rd August 2009, 06:23 PM
Did you try 'yum-complete-transaction'?

Mister B
23rd August 2009, 06:38 PM
I was running "yum update" when I lost my internet connection. I continued with "yum --skip-broken update" when I got it back. Now when I try to finish the update I get the errors:

Error: Missing Dependency: totem = 2.26.2 is needed by package totem-gstreamer-2.26.2-1.fc11.i586 (installed)
Error: Missing Dependency: PackageKit = 0.4.6-8.fc11 is needed by package PackageKit-glib-0.4.6-8.fc11.i586 (installed)
Error: Missing Dependency: perl = 4:5.10.0-68.fc11 is needed by package 4:perl-libs-5.10.0-68.fc11.i586 (installed)
Error: Missing Dependency: perl = 4:5.10.0-68.fc11 is needed by package 3:perl-version-0.74-68.fc11.i586 (installed)

How do I install those missing dependencies?

It's probably an issue with the RPM database being corrupted, not missing dependencies. Look for one of the guides to fixing a bad database.

isinias
24th August 2009, 01:06 AM
Did you try 'yum-complete-transaction'?

Thanks kulbirsaini that fixed it.