PDA

View Full Version : Stop Motion (any success!) (rpm rebuild/compiling failing)



isaac
23rd August 2009, 05:29 AM
(running Fedora 11 x86_64)


when trying to compile i get:


[root@dot stopmotion-0.6.2]# ./configure
checking for pkg-config... /usr/bin/pkg-config
checking for QtCore >= 4.0.1... configure: error: *** QtCore module not found or wrong version ***



i can't find a package for QtCore module


when i attempt to rebuild the source rpm i get



error: Failed build dependencies:
SDL_image1.2-devel is needed by stopmotion-0.4.1-1.src


i have SDL_image-devel installed, but i can't find SDL_image1.2-devel, i think it may be a MAndriva thing. can i somehow edit the source rpm to use SDL_image instead?


any tips?



optional reading:
i really like fedora better than ubuntu/mint but i might have to switch. i use fedora because i am an animator and i use maya 2009, but i need video editing programs for editing and a stop motion program for indulging in the physical side of animation.i know it's possible to get Maya running in ubuntu. does anyone know if it runs as well/stable in ubuntu?

i was about to switch, not having found a good video editor in the repositories, until i came across kdenlive, which is good enough for my needs. i want to install openmovieeditor, cinelerra, and stop motion, but when i attempt to compile from source i'm always met with problems such as above.

would it be worth while to switch to a distro i like using less and deal with setting up Maya 2009 on Kubuntu, and in return get a wealth of video editing software. I guess it depends on how well maya runs in ubuntu and whether i can figure out how to install Stop Motion in fedora.

Hlingler
23rd August 2009, 05:51 AM
Try:
yum install PyQt4 PyQt4-devel

Try again.

V

isaac
23rd August 2009, 07:13 AM
Awesome, thanks man. it is installed and working, if anyone knows about the source rpm problem, i'd still like to know just out of curiousity, i don't know much about editing rpm files or spec files

Hlingler
23rd August 2009, 08:43 AM
You can't (usually) use a Madriva SRPM with Fedora, without a lot of fixing and tweaking of the spec file, because of things like this (the two distros often use different package names).

If you want to try (why, now that you've got the source to compile ?), then unpack the SRPM, edit the spec file so that it reads "SDL_image-devel >= 1.2", and try again (not re-build from the SRPM, but rpmbuild from edited spec file). Prepare for more errors.

V

isaac
23rd August 2009, 03:33 PM
i see. i was actually curious more for future endeavours. i should notify the stop motion team as they have a mandriva version for download, and then a source RPM download supposedly for all other RPM distros. I don't think they've had much feedback from anyone but Ubuntu/debian users.


http://vimeo.com/isaacahloe

there are some animations, the latest maya one (QoWL) was done with linux but all the 2d/stop motion was done in osx/windows, UNTIL NOW BABY