PDA

View Full Version : Wine kamikazed after being fiddled with too much. Want to start over.



zorgoth
19th August 2009, 12:43 AM
I had a working version of Wine in the past, I had 1.1.23 from the repository and upgraded it to 1.1.27 from source because of a minor sound glitch with Wine + Java (which that fixed). Unfortunately, after I repeatedly uninstalled and reinstalled various versions of it (from source) to try to find one that didn't have either of one new bug or one old bug, I lost all sound in any wine app, whatever I do in wine config. Occasionally Test Sound worked, occasionally it did nothing, occasionally a little error box comes up, occasionally it crashed the program, but sound never appeared in Firefox (using Java or Flash) or WoW. I have never had this problem before on this computer.

Just now I decided to start over with a clean slate, so I uninstalled everything (with sudo make uninstall and the Add/Remove Software) and reinstalled it exactly the same way I set it up the first time, but now Wine will not open any programs whatsoever, not even Wine config.

Could someone tell me how to completely remove all trace of Wine that might cause it to behave differently than it would from a fresh install from my system without removing any of the programs I run in Wine (Mozilla Firefox (for Runescape; it works better), WoW, Sun Java, and Flash Player are the only ones) and then how to install Wine 1.1.27 on my computer while also having Wine Config and Regedit (these do not appear to come in the basic source package).

Incidentally, an unrelated matter: There was a WoW crash I had happen to me where WoW says some things I couldn't read and then repeats the same thing over and over and over so many times that the rest of it flies into oblivion. How can I pipe this into a file? I know basically what piping is but none of the tutorials I saw had an appropriate example or a general enough explanation of how it works to make my own.

zorgoth
19th August 2009, 12:53 AM
As for the recent bug it says:
wine client error:0: version mismatch 386/387.
Your wineserver binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?

which to me seems like it confirms my belief that I haven't done enough house-cleaning.

zorgoth
19th August 2009, 04:17 AM
Fixed. Solution was to install and uninstall each version in ascending order and then everything was good as new.

zorgoth
19th August 2009, 04:36 AM
Not fixed! Made a clean 1.1.23 installation but failed to upgrade to 1.1.27 as before.

zorgoth
19th August 2009, 05:57 AM
Uninstalled and reinstalled everything again, tried both compiling 1.1.27 from source and upgrading from 1.1.23 to 1.1.27 (doing ./configure while 1.1.23 was onboard and working properly) . I *cannot* use 1.1.23 because I get bad sound. Please help... (1.1.27 still says what it did on my second post).

zorgoth
19th August 2009, 08:16 AM
Fixed, finally - used yum erase to get rid of wine 1.1.23, restarted, and everything worked and i got 1.1.27 from source