PDA

View Full Version : does this mean i have to upgrade kernel headers?



vitasoy
17th August 2009, 12:10 PM
I've been trying to install a tar and I read somewhere that following the error message I'm seeing means I have to update kernel headers or something

[root@chris 2008_0925_RT2870_Linux_STA_v1.4.0.0]# !37
make
make -C tools
make[1]: Entering directory `/home/admin/Download/2008_0925_RT2870_Linux_STA_v1.4.0.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/admin/Download/2008_0925_RT2870_Linux_STA_v1.4.0.0/tools'
/home/admin/Download/2008_0925_RT2870_Linux_STA_v1.4.0.0/tools/bin2h
cp -f os/linux/Makefile.6 /home/admin/Download/2008_0925_RT2870_Linux_STA_v1.4.0.0/os/linux/Makefile
make -C /lib/modules/2.6.29.6-217.2.7.fc11.i586/build SUBDIRS=/home/admin/Download/2008_0925_RT2870_Linux_STA_v1.4.0.0/os/linux modules
make: *** /lib/modules/2.6.29.6-217.2.7.fc11.i586/build: No such file or directory. Stop.
make: *** [LINUX] Error 2
[root@chris 2008_0925_RT2870_Linux_STA_v1.4.0.0]#[
:confused:

.. i've tried "su yum update kernel" but it seems that i'm running the latest version possible...any ideas on how to solve this error?

markkuk
17th August 2009, 12:47 PM
yum install kernel-devel

vitasoy
17th August 2009, 12:54 PM
yum install kernel-devel

just did that successfully...I ran "make" again but now I've got this:

/home/admin/Download/2008_0925_RT2870_Linux_STA_v1.4.0.0/os/linux/../../os/linux/rt_profile.c:928: error: ‘struct task_struct’ has no member named ‘fsuid’
make[2]: *** [/home/admin/Download/2008_0925_RT2870_Linux_STA_v1.4.0.0/os/linux/../../os/linux/rt_profile.o] Error 1
make[1]: *** [_module_/home/admin/Download/2008_0925_RT2870_Linux_STA_v1.4.0.0/os/linux] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.29.6-217.2.7.fc11.i586'
make: *** [LINUX] Error 2


this is off topic from the thread title :( but any ideas how to fix this? thanks

markkuk
17th August 2009, 01:16 PM
The code you are compiling isn't compatible with kernel version 2.6.29 or later. Find an updated driver source package.

EnglandA
17th August 2009, 02:59 PM
HHhmmmm you do know that if you add the rpmfusion repository and then yum install kmod-rt2870 you shouldnt need to do this.