PDA

View Full Version : java-1.6.0-openjdk - do I need it?



Palooka
7th August 2009, 05:32 PM
Hi,

Sorry if this is something of a newbie question.
Fedora 11. I have the following two packages installed:

java-1.6.0-openjdk
java-1.6.0-openjdk-plugin.

According to yum there are no other packages dependent upon them. They are not causing me any issues, but I would prefer to remove them if I don't need them. I don't do any Java development.

Can anyone advise what they are used for?

Thanks,
Palooka

CSchwangler
7th August 2009, 05:49 PM
Firefox needs Java for certain web sites to display correctly and if you have OpenOffice installed, that would need it too for certain functionality. Both do not require it, so that is probably the reason why you have no dependencies.

Palooka
7th August 2009, 06:00 PM
Very many thanks for the advice. I do use Firefox and OpenOffice, so I'll hang on to them then.

Cheers,
Palooka