View Full Version : xsane problem with Fedora 11

1st August 2009, 02:03 PM
Since installing F11, my Canon LIDE 50 scanner refuses to work. xsane 0.996 produces an error message:
Failed to start scanner: Error during device I/O.

sane-find-scanner says it is there:
found USB scanner (vendor=0x04a9 [Canon], product=0x2213 [CanoScan], chip=GL841?) at libusb:001:006

But scanimage -L claims:
No scanners were identified. ...
except once when it admitted:
device `genesys:libusb:001:006' is a Canon LiDE 35/40/50 flatbed scanner

I reluctantly tested the scanner on a Windoze machine and it works perfectly. And it worked perfectly under F10.


1st August 2009, 02:17 PM
Permissions? Try to use the scanner as a root user.

1st August 2009, 02:22 PM
i have no idea if the scanner is supported, you should have a look at if so... if not.. dont waste time. setup Virtualbox 2.2.4.. install a usuall Win XP inside... enable USB.... use the scanner like normal... safe your scans on an usb stick.. disable then in the running V-Box.. and sssssssssst.. its shown under linux with ur fresh scanned stuff.....

Easy? Dont waste time when the solution is so close ;)


David Batson
1st August 2009, 02:43 PM
I ran into a similar problem with my Canon PIXMA MP600 multifunction printer/scanner. The following solution worked for me.

Turns out the device I/O error does not happen if after acquiring the preview I go to the preview window and select a sub-rectangular region and then I hit the zoom to selected button and then scan. So for now all I do is I acquire preview, select a window that is about 90% of my full scan window and then hit zoom to selected and then scan.


Note that I am using Canon's Linux drivers downloaded from Canon Austrailia. I don't see Linux drivers there for the CanoScan LiDE 50 scanner.

David Batson
1st August 2009, 02:48 PM
Just found this with Google. Maybe it will help.

1st August 2009, 08:27 PM
This doesn't seem to be a permissions problem: running xsane as root still produces the I/O error message. The www.patrickmin.com tip is interesting, but 'scanimage -L' can't find the scanner, and a test scan (by root) produces:
scanimage: no SANE devices found

The Canon LIDE 50 is supported by SANE, worked happily under Fedora 10, works under Windows. xsane won't provide a preview, so David Batson's workaround won't work.

Under Fedora 10, xsane would also detect a Logitech webcam (which sane-find-scanner also detected): now it does not. I've tried disconnecting the webcam, but it makes no difference.

1st August 2009, 08:35 PM
Try the latest version, it isn't in the repo's yet.



1st August 2009, 08:53 PM
Same I/O error message with xsane 0.997

6th August 2009, 05:25 PM
Since installing F11, my Canon LIDE 50 scanner refuses to work. xsane 0.996 produces an error message:

I have the same problem with my HP-1209 all-in-one. sane-find-scanner locates and reports the printer, but scanimage -L cannot see it:
[root@HomeLinux Desktop]# sane-find-scanner

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x2f11 [psc 1200 series]) at libusb:002:003

[root@HomeLinux Desktop]# scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[root@HomeLinux Desktop]#
Doing this as root confirms it is not a DLL access problem, which is what Xsane help says it is.

The same printer with the same printer driver worked fine before I installed Fedora 11. It still works on Fedora 8, as I can confirm by plugging the USB cable into my laptop. (But that's a really clunky workaround!)

The workaround listed above won't work because I can never preview scan the image.

I tried installing the xsane 0.997 from rpm's (successfully) but that did not solve the problem.


- Bill

4th December 2009, 03:47 AM
that worked on fc10 (and earlier).

found USB scanner (vendor=0x04b8, product=0x084a) at libusb:001:004

appears hectordavie got short shrift on this one. "buy another scanner" is not a solution.

---------- Post added at 09:47 PM CST ---------- Previous post was at 09:41 PM CST ----------

um, this was not hard to find