PDA

View Full Version : Partition table currupt



Stevyn
21st May 2004, 05:31 PM
Originally, I had this configuration on one disk:

1 main ntfs partition for windows
Extended:
1 ntfs partition
Ext3 partition
linux swap partition

I installed FC2 and it came up with an error saying the partition tables were not correct, but they could be fixed and it recommended I simply ignore and proceed. I did and it installed fine. Both fedora and windows xp booted without problems. However I went into Partition Magic in windows and it came up with some errors saying LBA and CHS values were not equal and it could fix them. I chose to have it fix them and then it says the whole disk is corrupt and I should reformat and repartition the whole thing. I then went back to fedora and it was somehow out of disk space, however I think that was not correct. Not wanting to reinstall windows, I booted up Hiren's Boot CD (very good tool) and using one of the programs on there it detected that the extended partition was corrupt and it deleted them. I didn't mind because the only thing that was lost was the newly installed fedora and the 2nd ntfs partition had nothing meaningful on it so nothing important was lost. I went back into partition magic, it said everything was good. I made a new ext3 and swap partition from the free space and installed fedora on that again. The fc installer still came up with the same error that the program that set up the partitions did them improperly but it said to ignore. I did that, installed fc again and both windows and fc boot properly. However Partition Magic still says the same error. Well I don't want to tell it to fix it again because that screws the disk up. This is on a Dell Inspiron 8200 laptop so I'm limited in that I can't easily swap drives out or add additional ones.

Any ideas? I think Partition Magic might be the culprit, but I've never had problems installing other distros using the same method.

MisterEd
22nd May 2004, 06:35 AM
You are not alone. I had the same problem. I thought it was Partition Magic too. It happened again after I used Windows XP instead to set up all the partitions. I was going to post the follwing message but decided to add it to your thread when I saw in your post you had the same problem. :mad:

============================

System:
ASUS A7N8X Deluxe | Athlon XP 2800+
1GB (2x512MB) Corsair XMS PC2700
LiteOn 48x24x48 CD/RW | Memorex Dual DVD/RW
Maxtor 80/160/250GB WDC 60GB
Verto geForce FX5900 AGP
Pinnacle PCTV Pro PCI
US Robotic Performance Pro PCI
Maxtor SATA/150 PCI Card
Windows XP Pro | RedHat 9 | Fedora Core 1

IDE 1:
Master: Maxtor 80GB
Slave: WDC 60GB

IDE 2:
Master: CDRW
Slave: DVDRW

IDE 3:
Master: Maxtor 160GB
Slave: Maxtor 250GB

IDE 1 Master:
C: Windows XP Boot (NTFS)
D: Program (NTFS)
E: Programs (NTFS)
RedHat 9 (ext3)

IDE 1 Slave:
F: Data (FAT32)
Fedora Core 1 (ext3)
G: Data (FAT32)
H: Data (FAT32)

Preparation:
I used Partition Magic 8 to reduce the H: partition to about 512MB and left the remaining 12GB as unallocated for the Fedora Core to find. The Fedora Core 2 ISOs had good checksums so I used Nero to burn them at 16X. All the CDs passed the installation media check OK.

Installation 1:
I selected a custom installation like usual and installed Fedora Core 2 with no problems..except when I tried to reboot. GRUB tried to boot Windows XP but couldn't. A Windows XP repair installation di not fix the problem. Only a reformat of C: allowed me to boot XP again. I did a linux rescue on Fedora 2 to get it back again. I reinstalled the GRUB boot loader. Everthing seemed to be working.

PostMortem 1:
Norton's Disk Doctor showed no problems.
Partition Magic 8 showed Drive 1 (80GB) driveas "BAD" with error code 108.
It showed Drive 2 (60GB) as "BAD" with error code 110. Even though everything seemed to work I decided to repartition both drives reinstall everthing.

Installation 2:
I installed in this order: Windows XP Pro, RedHat Linux 9, Fedora Core 2. FC2 messed up the partitions again.

PostMortem 2:
Partition Magic showed both drives as having error code 110. The third and forth drives were OK. I repartioned both drives with the Windows XP Pro installation and reinstalled Windows XP. It still would not boot. When I ran FIXMBR it completed but warned me that the parition table was messed up. I used Linux Rescue to remove all the partitions this time. Windows XP installed OK then.

I have been using linux for over seven years and have had my shares of little problems but this has me stumped. Does anybody have any idea what caused the Fedora core 2 installation to trash my first two partitions?

BTW, the diagnostics also showed either (I forget) the partition size or endpoint to be off by about 1.

AKr89Bv
22nd May 2004, 08:16 AM
I had the same problems with a W2k/RH9/Debian/FC2R3-Combination
The only relevant I could find on the web was
http://www.redhat.com/archives/fedora-test-list/2004-April/msg00288.html
All worked well before installing FC2R3. I tried fixmbr and fixboot in W2k, which gave ok results but the W2k partition (hd0, part 1) couldn't be accessed.
How I got it running again: I changed the HDD-mode in the BIOS from Auto to LBA (as mentioned in the URL above), I started RH9 (from fd0) with kernel 2.4, then I deleted all fedora partitions with fdisk /dev/hda (mainly to trigger a new writing to the partition table), rebootet again from fd0 then rewrote grub to mbr with grub-install /dev/hda and rebootet again -> worked. Grub came up. W2k and RH9 and Debian Links are alle working again.
Now I'm downloading Archlinux ...

dragon
26th May 2004, 02:51 PM
Lots of people are having this problem - please take a look at my fedora forum posts at http://www.fedoraforum.org/forum/showthread.php?s=&postid=14703

I've noted a couple of solutions which have been discussed on various mailing lists (including the solution noted above)

This problem doesn't occur with all XP setups, but typically those with older BIO's or when partitions are created during setup.