PDA

View Full Version : eclipse install with dependency problems



vbdanl
31st July 2009, 01:44 PM
hi. i tried to install eclipse with the groupinstall. the first time i tried it, it said there were dependency problems, and i could try these to resolve: package cleanups, rpm -Va --nofiles --nodigest, and finally, install with skip-broken. i did those and here is the end of the install:

xmlrpc3-client.noarch 0:3.0-3.9.fc11
xmlrpc3-common.noarch 0:3.0-3.9.fc11
xmlrpc3-server.noarch 0:3.0-3.9.fc11

Skipped (dependency problems):
eclipse-subclipse.noarch 0:1.6.0-1.fc11 eclipse-svnkit.noarch 0:1.2.3-1.fc11
subversion-javahl.i586 0:1.6.1-4.fc11 subversion-javahl.i586 0:1.6.1-5.fc11
svnkit.noarch 0:1.2.3-1.fc11 trilead-ssh2.i586 0:213-5.fc11

Complete!

here is the output from the rpm command:
:/data $ rpm -Va --nofiles --nodigest
/var/tmp/rpm-tmp.TZmZ0r: line 851: IntegrateWithGNOME: command not found
warning: %verify(jre-1.6.0_14-fcs.i586) scriptlet failed, exit status 4
/var/tmp/rpm-tmp.eMAoFj: line 851: IntegrateWithGNOME: command not found
warning: %verify(jre-1.6.0_14-fcs.i586) scriptlet failed, exit status 4
Unsatisfied dependencies for lexmark-z700-cups-driver-1.1.1-1.i586:
libcrypto.so.0.9.7 is needed by lexmark-z700-cups-driver-1.1.1-1.i586
libssl.so.0.9.7 is needed by lexmark-z700-cups-driver-1.1.1-1.i586
libstdc++.so.5 is needed by lexmark-z700-cups-driver-1.1.1-1.i586
libstdc++.so.5(CXXABI_1.2) is needed by lexmark-z700-cups-driver-1.1.1-1.i586
libstdc++.so.5(GLIBCPP_3.2) is needed by lexmark-z700-cups-driver-1.1.1-1.i586


my questions:
since the eclipse install skipped 6 packages, is there something i should do to try and get those installed?
if i don't, will eclipse run, but just without some functionality?
how can i fix the lexmark dependency problems?

thanks for your help.

tuxthejedi
31st July 2009, 09:47 PM
why don't you try to install them manually ? maybe that'll work ;)

Debian (http://www.linux-archive.org/debian-user/)

vbdanl
1st August 2009, 04:20 AM
why don't you try to install them manually ? maybe that'll work ;)

stupid question on my part.. how do i do that?

tuxthejedi
1st August 2009, 11:00 PM
try yum install package name or download the rpm and use the rpm command (rpm -Uvh package.rpm) ;)