PDA

View Full Version : Brother 2040 Printer Problem



gatorcc
23rd July 2009, 01:14 AM
I believe I have installed my Brother HL 2040 printer on my Fedora 11 64 bit system. However, every time I click printer the printer goes through its warm up procedure but it does not print anything. There is paper in the tray and I know it was working when I was running Fedora 10. It is shown under the Printers heading under Administration.
Any ideas?

Min
25th July 2009, 05:50 AM
I have brother 2142 (should be variant of 2140).. I think the problem is the default driver chosen.. In mine it chose 2170w.. I don't which one is should change it to, but when i randomly pick other driver,, it does print white page.

rexbinary
25th July 2009, 06:20 AM
The HL-2060 driver is the recommended driver for your printer. Also Brother offers Linux drivers as well.

http://www.openprinting.org/show_printer.cgi?recnum=Brother-HL-2040

Min
25th July 2009, 06:54 AM
I have installed the driver from the brother and now my printer has worked

petermholmes
10th September 2009, 02:15 PM
The Brother driver worked for me too (HL-2040) but be aware that, if you already had the FC11 driver in there, you'll get a new printer entry under System->Administration->Printing.