PDA

View Full Version : Firefox very slow at first window launch



spacefrog
20th July 2009, 04:08 PM
Hello,

Since I installed F11 (i386 , Athlon 64), firefox is really slow to load the first window, afterwards it is OK. But it takes like 12 secs to get this first window!

Any idea about how to solve this?

regards,
Dan

compunix
20th July 2009, 06:16 PM
hi,
you must disable IPV6 in firefox...
1.type about:config in the address bar, and click on Enter key.
2.type ipv6 in the filter field.
3.high-light network.dns.disableIPv6 by right-clicking it, and change the value from false to true using Toggle.
This will disable IPv6. Most of DNS servers are still IPv4, so it will speedup Web browsing with Firefox.

spacefrog
20th July 2009, 06:45 PM
Meanwhile I found the solution. My Livna/Compiz configuration was not working perfectly. I guess for the first ffox window the system had to compile shaders (which takes time the first time). Now it rocks even on my old (but of great manufacturing quality - signal filters of level 5) Geforce 3 :)

SlowJet
20th July 2009, 07:00 PM
hi,
you must disable IPV6 in firefox...
1.type about:config in the address bar, and click on Enter key.
2.type ipv6 in the filter field.
3.high-light network.dns.disableIPv6 by right-clicking it, and change the value from false to true using Toggle.
This will disable IPv6. Most of DNS servers are still IPv4, so it will speedup Web browsing with Firefox.

The ipv6 issue hasn't been an issue for over a year.
In fact NetworkManager in F12 has a feature to support IPV6.

There have been a few bugs with dsn, dhcp, and such, but using Fx about was not the fix for the root cause, and never was.

SJ

compunix
20th July 2009, 07:09 PM
then you think "The ipv6 issue hasn't been an issue for over a year..." SlowJet?!

look at these:
http://kb.mozillazine.org/Error_loading_any_website
http://soniahamilton.wordpress.com/2009/01/09/speed-up-firefox-on-linux-disable-ipv6-lookups/
http://support.mozilla.com/en-US/kb/Firefox+cannot+load+websites+but+other+programs+ca n
http://en.kioskea.net/faq/sujet-758-disable-ipv6-will-speed-internet-connections
http://en.kioskea.net/faq/sujet-758-disable-ipv6-will-speed-internet-connections
http://ubuntuforums.org/archive/index.php/t-6841.html
http://www.roytanck.com/2008/10/31/firefox-slow-on-your-netbook-too-disable-ipv6/
http://en.opensuse.org/Disable_IPv6_for_Firefox

........

SlowJet
20th July 2009, 07:19 PM
Not on a updated Fedora 9,10,11,12?

As Miley Cryus says to her Dad, "Just because you say it twice, ..."
It all came from the same chicken coup.

SJ

spacefrog
20th July 2009, 08:43 PM
Meanwhile I found the solution. My Livna/Compiz configuration was not working perfectly. I guess for the first ffox window the system had to compile shaders (which takes time the first time). Now it rocks even on my old (but of great manufacturing quality - signal filters of level 5) Geforce 3 :)

actually that was a misleading interpretation, the problem occurs again, ffox is still slow at launch...

spacefrog
21st July 2009, 08:58 AM
Hi,

Observed issue:
firefox 3.5 is slow at launching

Eliminated possible causes:
It is not the machine power (under Win XP Pro and latest Ubuntu it launches in ~ 0.5 sec)

Has anyone an idea about what could possibly be a cause of program launch slowliness?

many thanks,
Dan

CSchwangler
21st July 2009, 12:03 PM
Do you have extensions/add-ons configured? Any RSS feeds subscribted to? As far as I know, all these are loaded during startup. Additionally, what happens if you clear your history?

spacefrog
21st July 2009, 01:40 PM
Do you have extensions/add-ons configured? Any RSS feeds subscribted to? As far as I know, all these are loaded during startup. Additionally, what happens if you clear your history?

I removed the single add-on I had -> still slow at startup
I tried disabling all unnecessary language packs, same result.

And actualy, the process reports no errors nor warnings. Here is the terminal trace: startup ok, running ok, closing ok:


> /usr/lib/firefox-3.5/firefox &
[2] 6222
[1] Done /usr/lib/firefox-3.5/firefox


I installed Epiphany browser to compare and it has the same problem. Starts up in more than 10 secs.
I imagine there is some kind of limitation somewhere linked to Gnome/Linux in my case. On Win XP Pro, on the same hardware firefox starts in ~ 1 sec and to my mind there is no preloading in Win XP for firefox.
Maybe the startup slowliness comes form the fact that I run a i386/i686 platform on a AMD 64. I used to try a amd64 platform and I did not have this problem. But on the other hand, I could not install lots of packages.
One could image the hard disk is slow, but this is not the case, on the contrary.
12 secs computing time on a Athlon K8 processor @ 2000 GHz is really a lot of time, I what the system needs to do during this time.

I will try preload, even if it is just a way to "hide under the carpet" some performance issues.
If someone has an idea do not hesitate to post, I am a bit stuck now.

many thanks,
Dan

JEO
21st July 2009, 07:43 PM
Did you set a hostname and a domain? That can cause applications that use the internet to start up slow. Look in /etc/hosts and /etc/sysconfig/network

jvinla
21st July 2009, 09:28 PM
You might checkout
https://developer.mozilla.org/En/Controlling_DNS_prefetching
When I added network.dns.disablePrefetch=true to about:config, Firefox started quicker and smoother.
Before doing this, Wireshark was showing a lot of dns activity on startup.

spacefrog
22nd July 2009, 01:10 PM
Did you set a hostname and a domain? That can cause applications that use the internet to start up slow. Look in /etc/hosts and /etc/sysconfig/network
I have no domain, a hostname of course. I found nothing abnormal in hosts and network files

spacefrog
22nd July 2009, 01:14 PM
You might checkout
https://developer.mozilla.org/En/Controlling_DNS_prefetching
When I added network.dns.disablePrefetch=true to about:config, Firefox started quicker and smoother.
Before doing this, Wireshark was showing a lot of dns activity on startup.

I see your point. It's a tricky question, disabling prefetching or not.
If you disable prefetch, it may accelerate the boot but on the other hand it slows down the internet experience. DNS queries are long responding apparently so in my opinion it is better to leave the dns prefetch because while you are busy reading something on a page ffox does his dns queries and when you decide to click a link the dns is already done so it speeds up the internet experience as a whole.

stefan1975
22nd July 2009, 01:28 PM
i have always found FF on fedora insanely slow. I tried a kazillion things that all helped a little (you can search this forum for firefox and find them tips). Using swiftfox or FF3.6 from SVN also helped somewhat over fedora's build.

In the end I just gave up and switched to opera full time on fedora. Not only does it startup faster, it also renders pages quicker, uses less memory and has a native x64 QT4 build.

spacefrog
22nd July 2009, 01:49 PM
i have always found FF on fedora insanely slow. I tried a kazillion things that all helped a little (you can search this forum for firefox and find them tips). Using swiftfox or FF3.6 from SVN also helped somewhat over fedora's build.

In the end I just gave up and switched to opera full time on fedora. Not only does it startup faster, it also renders pages quicker, uses less memory and has a native x64 QT4 build.

Very interesting, it's been a long time since I haven't tried opera.
There is still one add-on that could let me stick to ffox anyway: AdBlockPlus. It is so usefull to me that it can counter balance some inconvience easily. Maybe there is an effective ad Blocker also on Opera, is it?

stefan1975
22nd July 2009, 01:59 PM
Very interesting, it's been a long time since I haven't tried opera.

so you have been using it all along? :-)


There is still one add-on that could let me stick to ffox anyway: AdBlockPlus. It is so usefull to me that it can counter balance some inconvience easily. Maybe there is an effective ad Blocker also on Opera, is it?

well adblock+ was the one thing that made me stick to FF as well. I have since switched to Opera10 (beta2) and found it much better. you can use an urlfilter.ini in /home/{user}/.opera that does the addfiltering for you. it is not exactly as good as ab+ but for me it does a fine job, good enough not to switch back. you do have to update the ini file once in a while though.

http://usgadget.blogspot.com/2008/07/opera-adblock-block-ads-in-opera-like.html
http://operawiki.info/BlockAdvertisements

with user enabled javascripts applets it is said to block adds (google adds) even better, i did not try it though.

spacefrog
22nd July 2009, 03:13 PM
Russian site reference hehe, heavy stuff ^_^

Looks very interesting, I have installed Opera 9 (stable). And here we go again with the slow network problem :)
I can't find ipv6 blocking in opera about:config, is there another option which can solve this problem? I would not like to block ipv6 at system level...

spacefrog
22nd July 2009, 03:38 PM
For Opera, i had to block ipv6 using blacklist at system level,, it's ok eventually.
The adBlocker is very usefull and to my mind easyer to use than the one from FFox.
Opera seems fast enough, that's a good thing.

later,
Dan

stefan1975
22nd July 2009, 05:07 PM
Opera seems fast enough, that's a good thing.
Dan

try opera10 it is Soooooooooo much faster and better then 9.6

spacefrog
22nd July 2009, 05:17 PM
try opera10 it is Soooooooooo much faster and better then 9.6

ok, I give it a try :)

spacefrog
22nd July 2009, 05:34 PM
try opera10 it is Soooooooooo much faster and better then 9.6

It's faster I can notice! This compression technology is not just marketing ^_^
Hope there are no security flaws, because nowadays we manipulate sensitive data on the web pretty offen.

spacefrog
22nd July 2009, 10:02 PM
Opera 9 has an interesting AdBlocking mechanism.
Opera 10 has lots of features, but maybe too many and it slows down the browser unless you have a recent cpu I guess. I had some troubles chatting because the text was typed to late sometimes. And generally speaking Opera 10b doesn't run so smoth as ffox. The sole issue with ffox is the launching time, but I beleave it will be fixed in a later version, at least I hope so ^_^
So, in my opinion and on my platform / hardware, Firefox 3.5 > Opera 10b or 9

Dan