PDA

View Full Version : Firefox 3.5.x and hotmail javascript?



erroneus
20th July 2009, 05:44 AM
All other web sites and javascript seem to work fine. But the problem is that the site works fine with Windows Firefox 3.5.1. I have tested this with 3.5 and 3.5.1 which has yet to propagate to the mirrors same results.

What is it about the Javascript under these fedora linux packages that is different from the windows?

Does anyone else here run a similar setup and have a hotmail account? Are you having the same problem?

Demz
20th July 2009, 05:48 AM
have you tried ruinning that extension in firefox that fools pages to think its IE an not firefox?

erroneus
20th July 2009, 05:51 AM
User Agent? Yeah. No effect.

Demz
20th July 2009, 05:57 AM
yeah thats the one, umm there's a jit i think you might be able to put on False or whatever javascript.options.jit.chrome;false or try this one javascript.options.jit.content;true play around with either 2 but i think it maybe the last one, put it to False

in about:config

erroneus
20th July 2009, 01:44 PM
Okay, changed from false to true and no change. Played with other javascript related booleans and either no or worse effect. Turned off the other jit thing and it completely wouldn't work.

erroneus
20th July 2009, 05:12 PM
Okay, found the answer. It seems this happened to be a couple of years prior and I forgot about it. I needed to flush all cache, cookies and browser history and then it worked again. Not sure what had gone wrong exactly except that cookies and cache seem to play a strong role in how hotmail does its thing.