PDA

View Full Version : Problem playing CD with XMMS



deuch
24th September 2004, 10:18 AM
Hi ...

I've a strange problem ...

I'm using a latpop under Fedora Core 2 (a old laptop IBM A21e, celeron 700, 256 RAM ...)

When i play a CD with gnome-cd-player, sounds it's not very OK ... i'v a noise like 'crrrrrr' during listening ... and when i move the mouse, the noise is amplified ...

I try XMMS with digital extraction, and XMMS start to play and the soud is not very good ... and 4-5 seconds after the beginning of the CD, xmms stop play and it's impossible to start playing a track ...

And it's worth than that : after this stop, i can't play any sound !!! MP3/OGG doesn't work with alsaplayer, xmms, aplay ... a rebbot does nothing ... i've to shutdown my computer to be abble to play any sound ...

I don't understand why XMMS can play my CD and why gnome-cd-player provide a stange sound over the music ...

helps !!! :-)

deuch

Bradlis7
25th September 2004, 01:11 AM
Are you sure this is a problem with playing cd's? Could it be an alsa problem, where no sounds work? Can you play regular mp3's on xmms?

superbnerd
25th September 2004, 01:24 AM
Please post your pc specs, including but not limited to your mobo, video, sound.
It sounds more like a problem with alsa than with cds unless other sound formats play well like mp3 and ogg vorbis.

deuch
25th September 2004, 09:48 AM
Playing MP3 or others are OK ...

Playinf CD correctly is more difficult ...

I've a laptop :
IBM A21e
Celeron 700
256Mo RAM
HD 20G
Intel i810 audio
CD Drive 24x

I'm using FC2 with all official update :
kernel 2.6.8.1.521 and others ...

Maybe it can be the problem, but i'm usind dmix plugin ...

this is my modprobe.conf

alias eth0 e100

alias snd-card-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0

alias usb-controller uhci-hcd
alias net-pf-10 off

And my .asoundrc :

pcm.!default {
type plug
slave.pcm "swmixer"
}

pcm.swmixer {
type dmix
ipc_key 1234
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

Thanks for help :-)

deuch

deuch
25th September 2004, 10:49 AM
i tried xmms with OSS output instead alsa ... and it works ...

I don't understand ... with OSS sound is normal no problem but i lose benefits of dmix ....

Why alsa sound is crappy with my audio CD ?

deuch

deuch
27th September 2004, 12:35 PM
Anyone have an idea ???

deuch

puremourning
27th December 2004, 04:40 PM
have you tried muting your "input" devices. try kmix and fiddle with them. i had a similar problem and it was to do with my line in being 'on' at full valume