View Full Version : SB16 not loading in Fedora 11

13th July 2009, 01:20 AM
I'm trying to set up a pc to rip my old LPs. Dual PIII 600MHZ that I loaded Fedora 9 onto to see if it would work and it seemed OK so I downloaded Fedora 11 to put that on. Now it is not loading the kernel module for my Soundblaster 16 ISA pnp card although it was fine in Fedora 9. I can do a
$ modprobe snd-sb16
and that seems to work fine in that I can

[root@PIII600LPRIP ~]# cat /proc/asound/cards
0 [S16 ]: SB16 - Sound Blaster 16
Sound Blaster 16 at 0x220, irq 5, dma 1&5

and it apparently sees my card as this is the same response I got in Fedora 9 and if I

[root@PIII600LPRIP ~]# lsmod | grep snd
snd_sb16 11928 0
snd_opl3_lib 8760 1 snd_sb16
snd_hwdep 6580 1 snd_opl3_lib
snd_sb16_dsp 7524 1 snd_sb16
snd_sb_common 14476 2 snd_sb16,snd_sb16_dsp
snd_mpu401_uart 6272 1 snd_sb16
snd_rawmidi 18764 1 snd_mpu401_uart
snd_seq_device 5988 2 snd_opl3_lib,snd_rawmidi
snd_pcm 62520 2 snd_sb16,snd_sb16_dsp
snd_timer 17896 2 snd_opl3_lib,snd_pcm
snd 49044 11 snd_sb16,snd_opl3_lib,snd_hwdep,snd_sb16_dsp,snd_s b_common,snd_mpu401_uart,snd_rawmidi,snd_seq_devic e,snd_pcm,snd_timer
soundcore 5404 1 snd
snd_page_alloc 7572 1 snd_pcm

I get a response very similar to what I got in Fedora 9.
However after hours of reading what seems to be mostly outdated information on how to load kernel modules at boot time I still can't figure out how to do it. It seems that I am supposed to put something into a file in /etc/modeprobe.d , but I'm not sure it it is supposed to be in local.conf or sound.conf or possibly somewhere else or what I am supposed to put there or if I'm completely on the wrong track. I have experimented with putting the following two lines into each of those with no apparent effect.

alias snd-card-0 snd-sb16
options snd-sb16 index=0

Can anyone tell me what I am really supposed to be doing here?

13th July 2009, 03:42 AM
I used to have a soundblaster 16. Try adding the following line to the /etc/rc.d/rc.local file:

modprobe snd-sb16

14th July 2009, 08:24 PM
Thanks. That does get SB16 load but pulseaudio still doesn't seem to see the card. Is this perhaps because it is loading too late in the sequence or is it some completely different problem?

14th July 2009, 08:31 PM
Unfortunately it's an isa card. Those don't identify themselves automatically like pci cards do, and so the module doesn't get automatically loaded and probably pulseaudio doesn't check for isa cards. I don't know the solution to get pulseaudio to see it If you think it's because pulseaudio is loading before the driver module, try killing pulseaudio with pulseaudio -k, and see if anything improves when it respawns.

29th July 2009, 08:01 PM
I've only been able to work on this intermittently but have finally solved my problem. I used nano to create /etc/rc.modules adding the line 'modprobe snd-sb16' and then did >chmod +x /etc/rc.modules. Then I modified /etc/pulse/default.pa by commenting out lines to force use of the line 'load-module module-detect' rather than 'load-module module-hal-detect' so now PulseAudio sees my SB16 card and sound works again.

29th July 2009, 09:15 PM
Thanks for posting your solution!