View Full Version : Screensaver not Working

23rd September 2004, 07:02 AM
Trying it out tonight. Can't get the screensaver feature to work properly.

1. Selected "The Matrix" screensaver
2. Set to start automatically after 1 minute - box checked
3. Require password to stop - box checked

After 1 minute elapsed, the screensaver kicks in. Instead of the Matrix screensaver, I just get a black screen. I did have to enter the password to stop it.

So in all, only #2 and #3 really worked. Anyone got #1 to work?

What's this "Advanced Options" thing under the preview? Anyone tried that [yet]?

23rd September 2004, 07:06 AM
check the advanced tab and make sure you are not using power management that puts your monitor to sleep. does it work with other screen savers?

23rd September 2004, 07:30 AM
go to >preferences >screensaver and make sure under MODE you are not selecting BLANK SCREEN but that you are selectin ONLY ONE SCREENSAVER

23rd September 2004, 06:10 PM
GLMatrix or xmatrix? GLMatrix is pretty subtle, but looks really nice. Maybe you need to turn up the symbol density.

24th September 2004, 01:28 AM
1. Power management NOT turn ON.
2. Yes, only 1 screensaver is selected: The Matrix
3. No, it's not the GLMatrix--just "The Matrix" under Banners & Pictures

:confused: :confused:

Running KDE, if that matters.

24th September 2004, 01:40 AM
can you try to expand the time for screensaver....

24th September 2004, 02:13 AM
It's set to 7 minutes now before the screensaver starts. Let me change the session to Gnome and see if that makes any difference (which I don't think it should but what the heck).

Edit: Aha! I might be on to something. Logging in via Gnome and going through the screensaver option, it gave me an error. This is the message:

"The XScreenSaver daemon doesn't seem to be running on display ":0.0". Launch it now?"

I clicked OK, but it still had another error--something about xhost +localhost and something along the lines of File/Restart Daemon

24th September 2004, 05:41 PM
Are u running as root?

24th September 2004, 09:39 PM
Yes, running as root. It shouldn't matter for the screensaver under what profile you're currently logged in, should it?

24th September 2004, 09:53 PM
I think it does. I don't think xscreensaver allows you to run it under the root ID.

From the xscreensaver website:


Don't log in as root! :)

24th September 2004, 11:10 PM
Hmmm, then that poses another question about screensavers. On another computer (laptop), I'm running FC2 (as root). The Matrix screensaver works just fine on the laptop.

So if running as root disables the screensaver, how does one explain the laptop screensaver? Real puzzled now.

24th September 2004, 11:41 PM
As the FAQs mention, you can enable root to run the xscreensaver program. An example of that is using the xhost + command before starting the xscreensaver program.

The FAQs I linked to earlier and the site in general should have all the answers you need. I've never tried to run the screensavers as root, so I'm not sure why it works on one and not the other.

24th September 2004, 11:49 PM
i have tried to run the screen saver as root and it didn't work. it should, especially so I can use the lock screen feature for extra security if I get distracted while doing something as root. but then again you shouldn't hae to ever login in as root becuase we have the su and sudo commands.
is the matrix screen saver an included screensaver or an add on?

25th September 2004, 01:35 AM
The screensaver came with FC3 T2. It's just part of the core installation. Yeah, I'm still puzzled as to why it would work on the laptop but not on the desktop. Strange. Oh well. I'm not going to lose sleep over this. :)

25th September 2004, 04:11 AM
Screensaver works if youL
a. run as a regular user (not root) under the GNOME environment

Screensaver DO NOT work if you:
a. run as a regular user (not root) under the KDE environment
b. run as root under the KDE environment

It appears the screensaver do not function as described in the first post under KDE (at least for me). If someone can get it to work, I'd like to know. :)