PDA

View Full Version : pulseaudio multiple audio sources



M4rc0
23rd June 2009, 01:12 PM
I have pulseaudio installed here in Fedora 11 x86_64 but I cannot have multiple audio sources

In short, If I'm listening to music skype won't receive calls or I can't browse youtube, then I pause the music and I'm able to use skype, etc..

So I can only do one thing at once and I believe this multiple source/sink should be standard on pulseaudio, no?

This is what I have installed:

# rpm -qa | grep pulseaudio
pulseaudio-0.9.15-14.fc11.x86_64
pulseaudio-libs-0.9.15-14.fc11.x86_64
pulseaudio-libs-0.9.15-14.fc11.i586
pulseaudio-libs-glib2-0.9.15-14.fc11.x86_64
xine-lib-pulseaudio-1.1.16.3-2.fc11.x86_64
pulseaudio-libs-zeroconf-0.9.15-14.fc11.x86_64
pulseaudio-utils-0.9.15-14.fc11.x86_64
wine-pulseaudio-1.1.18-1.fc11.i586
pulseaudio-module-gconf-0.9.15-14.fc11.x86_64
pulseaudio-module-bluetooth-0.9.15-14.fc11.x86_64

I already took a look on /etc/pulse/system.pa to check if module-hal-detect is there and it seems to be:


### Automatically load driver modules depending on the hardware available
.ifexists module-hal-detect.so
load-module module-hal-detect
.else
### Alternatively use the static hardware detection module (for systems that
### lack HAL support)
load-module module-detect
.endif


"avahi-daemon" is also running
and I have no .asoundrc file set

Trying many things here but don't know what to try next.

Any advice?

M4rc0
24th June 2009, 10:06 PM
Come on, no one has pulseaudio working properly in Fedora11 ?

I'm willing to try anything here, it's also a good learning experience.

sideways
24th June 2009, 11:09 PM
Problem is, skype is not a supported app, and it's not considered compliant with the alsa standards.

You'll probably find you can play mp3s via you favourite gnome player and watch youtube at the same time for example (although you might notice weird behaviour like one app controlling the volume of the other app, due to "flat volumes" in pulse audio)

Draciron
25th June 2009, 04:50 AM
To be honest pulseaudio is a piece of junk. Set your apps to use other options such as ALSA, ESD or OSS. JACK and Fedora have never gotten along and Pulseaudio I haven't seen work well on any distro.

M4rc0
25th June 2009, 06:48 AM
sideways, I just tried watching a youtbe video with sound (works) and listen to music on rythmbox (no sound but playing).
So this should work by default, right?
Could you tell me what packages and configuration do you have so we compare to what's missing on mine?

Draciron, If the app gives me the option to set which one to use I would try it.
But I can't choose that for youtube nor for music players (at least not songbird). You think without pulseaudio installed this would work?


It's not like I listen to multiple sources all the time, but it can be annoying when a program won't give you a alert of some sort, like Pidgin new msg or a Skype call because you are listening to music or forgot a youtube tab opened on firefox.

Draciron
25th June 2009, 07:56 AM
With apps like XMMS, Audacious, Audacity just go to preferences and change over. I suggest ALSA which is pretty tolerant to multiple sources. With KDE/Gnome you'll need to change the default. As for youtube either your using a plugin like mplayer which you can edit the preferences or your using the default sound preferences for your window manager.

With Pidgin go to tools -> preferences -> sounds tab -> Method (choose the sound option you want)

Uninstalling will probably have too many dependancies. I don't think you can actually do it without wrecking a whole series of apps.

M4rc0
25th June 2009, 08:12 AM
Actually removing just "pulseaudio" and "alsa-plugins-pulseaudio" fixes it as I did it before.
But I installed pulseaudio back to have Bluetooth support.

First I will try your suggestion, if it doesn't work out than I will have to remove it again those 2 packages.

I'm using XFCE and in "Sound Preferences" I don't have other options:
- In input my only choice is "Internal Audio"
- And in output I have "Internal Audio" or "Simultaneous output to Internal Audio" (chosen)

This last option I got after I installed "Pulseaudio Preferences" thinking that it would fix this problem (read the simultaneous in the description of the package)

For the applications I haven't go much luck:
- Skype as expected, doesn't work and requires the sound all by himself (with pulseaudio installed)
- Songbird you can't choose the audio
- For Firefox I have the plugins that are shown in the attached screenshot. Don't know which one I should disable
- Pidgin, good that should work

So far this says that Alsa > Pulseaudio. But then I will lose the Bluetooth support :(

EDIT: Firefox plugins screenshot http://tinypic.com/view.php?pic=wcdekw&s=5

sideways
25th June 2009, 12:15 PM
Instead of removing pulseaudio you can try (as root)


mv /etc/alsa/pulse-default.conf /etc/alsa/pulse-default.confx

and restart

or, alternatively, just remove alsa-plugins-pulseaudio

M4rc0
26th June 2009, 05:51 PM
Draciron and sideways, thanks for the replies

I tried uninstalling alsa-plugins-pulseaudio just to be notified that it is already uninstalled.

After that I tried many different combinations. That's where it gets confusing to realize which one was the best alternative since it's so many different ways
(disabling alsactl.conf, installing alsa-plugins-pulseaudio, trying different settings with each combo, etc..)

I tried re-installing alsa-plugins-pulseaudio and to my surprise youtube and songbird would play together, but skype would have no microphone.
And unfortunately skype is priority here in this laptop (work > fun).

Moving alsactl.conf to alsactl.confx like suggested made songbird stop working.
Without pulseaudio would be a nice one but then i would lose bluetooth (easy) support.

I'm sure i would find a combination that would probably work. But skype is there always bitching.
So I guess I should just wait for a pulseaudio compatible version.

So my final combination that I will probably keep it, is with pulseaudio installed and without alsa-plugins-pulseaudio (and without ~.asoudnrc or any tweaks, not necessary so far).

Sorry for the confusing in this topic but this is a bit complicated to me :S

I appreciate your help.

pankajp
2nd July 2009, 06:25 AM
Hi,
I dont know from where the pulseaudio issues for various people come from, it actually works for me pretty well, including multiple sound sources and youtube and stuff (except jack). Actually i not using skype in F11 x86_64 (no native skype 64 bit, dont want to install 32 bit libs). However in F10 32 bit i had installed skype from the skype repo and it worked well. The only configuration i needed was setting up the appropriate audio devices in the skype preferences. I did *not* tweak any config file. I think you should first check there.