PDA

View Full Version : How do I reinstall grub in Fedora 11?



Pumpino
20th June 2009, 11:33 AM
I've restored a Clonezilla image of my Fedora 11 ext4 installation but realised that I hadn't backed up the ext3 /boot partition. I decided to create a Clonezilla image of the ext3 /boot partition from my laptop, as that has exactly the same partition scheme. I've restored that. I realise it may not work but it might save me reinstalling F11 from scratch.

How does one reinstall grub in Fedora 11 given that /boot is on a separate partition? Booting from the F11 DVD in rescue mode, running chroot /mnt/sysimage and grub-install /dev/sda doesn't work.

scottro
20th June 2009, 12:04 PM
This is from 2004, not sure if it's still valid

http://fedoranews.org/contributors/bob_kashani/grub/

Towards the end, it mentions the separate /boot partition.

scottro
20th June 2009, 12:07 PM
Actually, here's another. In this case, if sysimage isn't mounting both /boot and /, you can choose to mount manually.

http://sidvind.com/wiki/HOWTO_Restore_GRUB_after_Windows_XP_installation-cd

Note that I found these in about 30 seconds by googling. using the term


restore grub with separate /boot partition

On the other hand, I haven't tested either one. :)

MadLikeDocBrown
25th November 2009, 02:12 AM
thx for help in advance

sorry if i'm not in the right place. new to the site and don't know yet where to post new threads

M.

Edit: Hello,

i hope this is not totaly off-topic..
today i tried putting a password and a lock on my grub loader. i backed up the menu.lst file to menu2.lst
after wards i edited the file to have an md5 password. I locked the first linux entry; locked the last (windows) entry and deleted the remaining entries containing precious linux kernel versions.
after rebooting i found that linux(fedora 11 btw) didnt want to load anymore. After i gave in my password and booted it would stop right after on the white blinking cursor.
Windows had no problems loading tho.
So i booted with my fedora install cd, went to the boot/grub directory and deleted the original menu.lst file. after that i cp the menu2.lst (backup file) to menu.lst thus restoring the file with the right settings. i rebooted again and linux still doesn't work
it seems that grub is still loading off the first (supposedly deleted menu.lst file) as it's still asking me for a password and doenst contain the precious deleted entries.

is there any way i can solve this?
or how can i tell the grub to choose the right menu.lst file so i can launch linux again?

thx for help in advance

sorry if i'm not in the right place. new to the site and don't know yet where to post new threads

M.

stoat
25th November 2009, 02:25 AM
Hello MadLikeDocBrown,

And welcome to FedoraForum.org. I locked this thread since it was old enough to be considered over and done with, and since you have started a new thread with the same content. A good idea, BTW. But in addition to being against the posting guidelines, it's not a good idea to double post because it can easily result in divergent, confusing, and even outright conflicting advice being given without the benefit of discussion to resolve it all. Then you end up referring people back and forth attempting to do just that. It's all happened before. Anyway, I hope you get the answer to your problem in the other thread.