PDA

View Full Version : problem with AVI (sound) F10 - VLC



Chilly Willy
19th June 2009, 05:01 AM
After doing a preupgrade from F9 to F10 all went well but I have a minor but albeit annoying sound problem. I did a search here but didn't find anything that seemed relevant.

When I play any AVI files in VLC the audio is chopped, sounds like another track is playing alone with it & is somewhat distorted. FLV & other formats that I've checked all play fine. I had issues with VLC in F9 at the beginning that were bug related but had ALL of them resolved at the time of upgrade so VLC was working perfectly.

What may have changed in the upgrade process? What should I look for or check?
Also, I lost audio altogether when troubleshooting. Like I muted it. After a reboot, it all came back as described above.

Any help to point me in the right direction will be much appreciated.
THANKS :cool:

glennzo
19th June 2009, 05:44 AM
I suggested this page http://fedorasolved.org/Members/fenris02/pulseaudio-fixes-and-workarounds/?searchterm=mplayer to someone else. Admittedly I didn't read much of it but it seemed to offer some hope.

Chilly Willy
19th June 2009, 06:43 AM
Thanks for the info but unfortunately (for what I tried of it that seemed to relate) nothing helped. - given that it is only one format, this MAY be a bit of a "needle in a haystack" to find. - If it wasn't one of my main formats, I wouldn't worry about it & just run in another format.

Chilly Willy
19th June 2009, 06:02 PM
Any other ideas? - anyone???

I did some more checking & it appears to be the way they are "internally formatted" (the audio & video parts). I had this same problem with F9 at the beginning but was bug related & got it all worked out LONG before the F10 upgrade. So the question still remains, what changed?

LionelHutz
19th June 2009, 07:49 PM
Have you tried forcing VLC to use ALSA?
Tools/Preferences/Audio
Output Type: ALSA audio output

Chilly Willy
19th June 2009, 10:12 PM
It's already using ALSA...

I got tired of trying to get it in VLC & tried a couple of other players. I chose TOTEM as it has a saveable playlist that I wanted. I launch my music videos from them.

So, in a way, I guess the problem is resolved - for ME anyway.

Thanks to all that responded.