PDA

View Full Version : Sound without Gnome



senap
13th June 2009, 03:23 PM
Hi everyone,

I just installed Fedora 11 and with Gnome, everything works right out of the box, which is quite impressive. Good job, everyone!

Thing is, I'm a bit old-fashioned, and I don't want to run a desktop system. I just want to start a window manager and be done with it, and in older Fedoras, this has not been a big problem, and mostly it isn't i F11 either: just add a .xinitrc and things start. But I can't get the sound to work!

So: can anyone please tell me what it is that Gnome does at session startup that starts the sound, and that I have to do manually?

Thanks for your help.

scottro
13th June 2009, 04:37 PM
Snicker. Welcome to my world. (That's not a nasty snicker, it's just something that I've frequently mindlessly ranted about all over these forums.)

This actually goes way back to November of 2007, where they decided that sound should be tied in with consolekit. At that time, you still had a choice of whether or not to start consolekit at bootup.

Usually, you can fix it by editing /etc/security/console.perms.d/50-default-perms (or something similar, whatever file is in there.)


Add the following (the dsp stuff *might* not be necessary, but shouldn't hurt--I think pulse doesn't use /dev/dsp, but I'm not an expert on any of this).

At the top where you'll see similar lines

<sound>=/dev/dsp* /dev/snd/*


At the bottom, where once again, you'll see similar lines


<console> 0666 <sound> 0600 root


That usually fixes it.

senap
13th June 2009, 04:47 PM
scottro, thanks a billion! That worked perfectly. I'm so happy that I'm not alone with these views - I'll leave my own mindless ranting on the subject for another time.

Thanks again!

scottro
13th June 2009, 05:35 PM
Glad it worked.

It's not just Fedora with this type of issue--I think many of the distributions aiming to produce a working, out of the box desktop, wind up tying sound, networking, etc., to a desktop.

senap
11th July 2011, 12:20 AM
Hello again, everyone. I just installed Fedora 15, and indeed, I have the same problem again: no desktop system means no sound. This time, things seem to have changed, because the fix earlier in this thread won't work - the desktop permission files looks different now.

Does anyone have any idea?

sonoran
11th July 2011, 12:55 AM
I sucessfully installed OSSv4 to a minimal F15 system running only openbox. No Gnomeish stuff was ever installed, though.

It seems to be easier to do a minimal install and then add what you want than to extricate yourself from the fedora-gnome-pulseaudio-*kit group hug.

JohnVV
11th July 2011, 01:17 AM
if you want a headless system , then fedora is not the good choice

I would look into using Arch or RHEL or Debian stable

senap
11th July 2011, 01:42 AM
I'm not after a headless system, only a system with a standalone window manager without a desktop system.

smr54
11th July 2011, 02:36 AM
In my experience, sound has worked pretty well now for a couple of years, and Gnome has not been Gnecessary.

Make sure you're a member of the audio group. Yes, the fix of several years ago is no longer relevant.

Also, you might want to install alsa-utils and then run alsamixer (just type alsamixer, it can run in terminal too.) Make sure that nothing important has an MM at the bottom (which means it's muted--you can change that by hitting the letter m) and raise sound level if necessary. I find, for example, that I always, on this desktop, have to make sure that "Front" is unmuted and at a reasonable level. (It always catches me by surprise, as the speakers connect at the back, and I'm a literal sort.)

senap
11th July 2011, 01:10 PM
smr54, thank you for your answer. I had tried that but got some weird behaviour, but a reboot got things up and running. Thanks again!