PDA

View Full Version : Google Earth & Error code 29 on startup - FC11



BlownCPU
13th June 2009, 03:13 PM
Hi,

Can someone please point me in the right direction where to find a solution for Error code 29 as this comes up erey time I run Google Earth under FC11, FC9 was fine.

I have a network connection and everything is "as normal" on my desktop.

Thanks

Blown CPU

Dangermouse
13th June 2009, 03:23 PM
Google is performing maintenace at the moment, its probably best to wait for a few hours till they have finished


On 6/13/09, our engineers will be performing site maintenance from approximately 10:00 AM to 2:00 PM PDT.

BlownCPU
13th June 2009, 11:18 PM
Unfortunately I've had this problem for over a month and even using your script I have no joy.
I do believe it is a FC11 + Googleearth problem

Blown CPU

TheBigRed
14th June 2009, 07:27 PM
can't start google earth on fc11 x86_64
I have installed google earth with this script http://dnmouse.org/autoten.html

# rpm -qa |grep google
googleearth-5.0.11733.9347-1.fc11.i586

Stacktrace from glibc:
./googleearth-bin [0x806c343]
./googleearth-bin [0x806c8b6]
[0xb38400]
/usr/lib/libGL.so.1(glXMakeCurrentReadSGI+0x146) [0x1aa4909]
/usr/lib/libGL.so.1(glXMakeCurrent+0x16) [0x1aa4b7c]
/usr/lib/googleearth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext19inter nalMakeCurrentEv+0x33) [0x461df33]
/usr/lib/googleearth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext21inter nalCreateContextEv+0x1aa) [0x461e14a]
/usr/lib/googleearth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext4openEv +0x96) [0x4640e26]
/usr/lib/googleearth/libevll.so(_ZN5earth4evll13VisualContext11OpenCont extEN3Gap3Gfx25igRenderDestinationFormatERKNS0_8In itInfoE+0x101) [0x2949a01]
/usr/lib/googleearth/libevll.so(_ZN5earth4evll13VisualContext4initERKNS 0_8InitInfoE+0x22d) [0x2954b6d]
/usr/lib/googleearth/libevll.so(_ZN5earth4evll17RenderContextImpl4initE RKNS0_8InitInfoE+0x87) [0x281d7a7]
./librender.so(_ZN12RenderWidget6SetApiEPN5earth4evl l3APIE+0x47) [0x1930e67]
./librender.so(_ZN5earth6render12RenderWindow12creat eWidgetEv+0xae) [0x191092e]
./libgoogleearth_lib.so(_ZN5earth6client12ModuleWidg et9showEventEP10QShowEvent+0x8e) [0xbf414e]
./libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x7cf) [0x49315f]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_hel perEP7QObjectP6QEvent+0xa8) [0x451130]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6 QEvent+0x122) [0x458916]
./libQtCore.so.4(_ZN16QCoreApplication14notifyIntern alEP7QObjectP6QEvent+0x9a) [0x2242f2]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x11f) [0x495fc3]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveE v+0x7b) [0x495d0f]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x15c) [0x495e98]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveE v+0x7b) [0x495d0f]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x15c) [0x495e98]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN7QWidget10showNormalEv+0x4a) [0x48b80e]
./libgoogleearth_lib.so(_ZN10MainWindow18readScreens izeInfoEv+0xbfa) [0xbc595a]
./libgoogleearth_lib.so(_ZN5earth6client11Applicatio n12SetupMainWinERK7QStringb+0x1f0) [0xc2e890]
./libgoogleearth_lib.so(_ZN5earth6client11Applicatio n3runEv+0x313) [0xc2f5f3]
./googleearth-bin(main+0x286) [0x806cde6]
/lib/libc.so.6(__libc_start_main+0xe6) [0xe80a66]
./googleearth-bin [0x806bad1]

We apologize for the inconvenience, but Google Earth has crashed.
This is a bug in the program, and should never happen under normal
circumstances. A bug report and debugging data are now being written
to this text file:

/root/.googleearth/crashlogs/crashlog-FD32B866.txt

This bug report will be sent to Google automatically next time you run
Google Earth. Its data, which contains no personal information, will help
us correct problems without bothering you further. If you would rather
this info not be transmitted, please delete the above file before running
the program again. If you want bug reports to NEVER be sent, remove the
above 'crashlogs' directory's read/write permissions.

Is there any solution ?

bob
14th June 2009, 07:52 PM
Maybe it's a 64 bit problem? Just installed using Dangermouse's script on my F11 32 bit and it's working perfectly.

leigh123linux
14th June 2009, 08:19 PM
can't start google earth on fc11 x86_64
I have installed google earth with this script http://dnmouse.org/autoten.html

# rpm -qa |grep google
googleearth-5.0.11733.9347-1.fc11.i586

Stacktrace from glibc:
./googleearth-bin [0x806c343]
./googleearth-bin [0x806c8b6]
[0xb38400]
/usr/lib/libGL.so.1(glXMakeCurrentReadSGI+0x146) [0x1aa4909]
/usr/lib/libGL.so.1(glXMakeCurrent+0x16) [0x1aa4b7c]
/usr/lib/googleearth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext19inter nalMakeCurrentEv+0x33) [0x461df33]
/usr/lib/googleearth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext21inter nalCreateContextEv+0x1aa) [0x461e14a]
/usr/lib/googleearth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext4openEv +0x96) [0x4640e26]
/usr/lib/googleearth/libevll.so(_ZN5earth4evll13VisualContext11OpenCont extEN3Gap3Gfx25igRenderDestinationFormatERKNS0_8In itInfoE+0x101) [0x2949a01]
/usr/lib/googleearth/libevll.so(_ZN5earth4evll13VisualContext4initERKNS 0_8InitInfoE+0x22d) [0x2954b6d]
/usr/lib/googleearth/libevll.so(_ZN5earth4evll17RenderContextImpl4initE RKNS0_8InitInfoE+0x87) [0x281d7a7]
./librender.so(_ZN12RenderWidget6SetApiEPN5earth4evl l3APIE+0x47) [0x1930e67]
./librender.so(_ZN5earth6render12RenderWindow12creat eWidgetEv+0xae) [0x191092e]
./libgoogleearth_lib.so(_ZN5earth6client12ModuleWidg et9showEventEP10QShowEvent+0x8e) [0xbf414e]
./libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x7cf) [0x49315f]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_hel perEP7QObjectP6QEvent+0xa8) [0x451130]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6 QEvent+0x122) [0x458916]
./libQtCore.so.4(_ZN16QCoreApplication14notifyIntern alEP7QObjectP6QEvent+0x9a) [0x2242f2]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x11f) [0x495fc3]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveE v+0x7b) [0x495d0f]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x15c) [0x495e98]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveE v+0x7b) [0x495d0f]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x15c) [0x495e98]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+ 0x146) [0x495e82]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0 x42) [0x495ee6]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0x4964bb]
./libQtGui.so.4(_ZN7QWidget10showNormalEv+0x4a) [0x48b80e]
./libgoogleearth_lib.so(_ZN10MainWindow18readScreens izeInfoEv+0xbfa) [0xbc595a]
./libgoogleearth_lib.so(_ZN5earth6client11Applicatio n12SetupMainWinERK7QStringb+0x1f0) [0xc2e890]
./libgoogleearth_lib.so(_ZN5earth6client11Applicatio n3runEv+0x313) [0xc2f5f3]
./googleearth-bin(main+0x286) [0x806cde6]
/lib/libc.so.6(__libc_start_main+0xe6) [0xe80a66]
./googleearth-bin [0x806bad1]

We apologize for the inconvenience, but Google Earth has crashed.
This is a bug in the program, and should never happen under normal
circumstances. A bug report and debugging data are now being written
to this text file:

/root/.googleearth/crashlogs/crashlog-FD32B866.txt

This bug report will be sent to Google automatically next time you run
Google Earth. Its data, which contains no personal information, will help
us correct problems without bothering you further. If you would rather
this info not be transmitted, please delete the above file before running
the program again. If you want bug reports to NEVER be sent, remove the
above 'crashlogs' directory's read/write permissions.

Is there any solution ?

Try setting selinux to permissive mode and test again.

leigh123linux
14th June 2009, 08:19 PM
Maybe it's a 64 bit problem? Just installed using Dangermouse's script on my F11 32 bit and it's working perfectly.

It works OK here on 64 bit.

TheBigRed
14th June 2009, 09:09 PM
same issue after set selinux to permissive mode.

leigh123linux
14th June 2009, 09:19 PM
same issue after set selinux to permissive mode.

Try uninstalling & reinstalling google earth.


It works fine here on rawhide.


[leigh@localhost ~]$ googleearth
[leigh@localhost ~]$ rpm -q googleearth
googleearth-5.0.11733.9347-1.fc11.i586
[leigh@localhost ~]$ uname -m
x86_64
[leigh@localhost ~]$ cat /etc/fedora-release
Fedora release 11.90 (Rawhide)
[leigh@localhost ~]$


P.S check selinux troubleshooter for error messages.

TheBigRed
15th June 2009, 05:46 PM
Try uninstalling & reinstalling google earth.


It works fine here on rawhide.


[leigh@localhost ~]$ googleearth
[leigh@localhost ~]$ rpm -q googleearth
googleearth-5.0.11733.9347-1.fc11.i586
[leigh@localhost ~]$ uname -m
x86_64
[leigh@localhost ~]$ cat /etc/fedora-release
Fedora release 11.90 (Rawhide)
[leigh@localhost ~]$


P.S check selinux troubleshooter for error messages.

I've reinstalled googleearth the third time, but no lock.

# uname -m
x86_64

# cat /etc/fedora-release
Fedora release 11 (Leonidas)

In the meantime selinux is completly disabled.
Can i give you mor informations or is it better to wait untile give any reaction to the crashlog that would be automatically sent to googleearth every start.

[EDIT]
Workaround with NVidia 3d party driver on x86_64 is to install the following packages:

# yum install kmod-nvidia akmod-nvidia xorg-x11-drv-nvidia-libs.i586

message: no connection to the GE Server and the map/Earth isn't displayed

# yum install libxml2.i586 mesa-libGL.i586 gtk2.i586 libSM.i586 nss-mdns.i586 nss-mdns.x86_64

heberv
15th June 2009, 06:21 PM
You need the 3d drivers of your video card, and if you are using 64bit version of Fedora need

for nvidia:
xorg-x11-drv-nvidia-libs-180.51-1.fc11.i586

i don't have an ati but probably you need 32bit drivers too.

BlownCPU
16th June 2009, 12:56 AM
Any chance of going BACK ON TOPIC.... which is after a successful installation the error code 29 comes up and no connection to the network by that I mean GE does not display the map/Earth.

Blown CPU

bob
16th June 2009, 01:15 AM
Check to see if this is installed: nss-mdns

From the Ubuntu Forums, it seems as if lib32nss-mdns is required and missing in their distro. Not sure if this is exactly the same 'fix' but nss-mdns is installed on my machine and Google Earth is working fine. Maybe something...maybe nothing...but at least it's a 'bump'. :D

BlownCPU
16th June 2009, 09:19 AM
Thanks, yes. it's there.



[root@mylinux ~]# rpm -qa | grep nss-mdns
nss-mdns-0.10-7.fc11.x86_64
[root@mylinux ~]#


Blown CPU

leigh123linux
16th June 2009, 04:29 PM
Thanks, yes. it's there.



[root@mylinux ~]# rpm -qa | grep nss-mdns
nss-mdns-0.10-7.fc11.x86_64
[root@mylinux ~]#
Blown CPU


That isn't any good as google earth is a 32bit app.

I don't even have it installed.



[leigh@localhost ~]$ rpm -q nss-mdns
package nss-mdns is not installed
[leigh@localhost ~]$

Dangermouse
16th June 2009, 05:04 PM
This should work fine do below, it doesnt need nss-mdns but the deps it installs it does.

su
yum install mesa-libGL.i586 nss-mdns.i586

BlownCPU
18th June 2009, 10:16 PM
YES, I erased nss-mdns-x86_64 and installed the above !!!!

Thanks :)

Blown CPU

borchen
21st June 2009, 09:17 AM
I also could not get Google Earth to work under Fedora 11 x86_64, but now it finally runs.

- When I installed Fedora 11 I also installed the latest NVIDIA drivers 185.18.14 (from the NVIDIA site)
- I then tried to install Google Earth; it did not work, because some packages were missing, so I
installed all of them. After that it successfully installed, but I got a "Segmentation Fault" all the time.
- I set SE Linux to "Permissive Mode", but still I got the dreaded "Segmentation Fault"... :(
- I then installed the older NVIDIA driver 180.60 over the previously installed newer version and finally Google Earth worked! :)
- Finally I reinstalled the latest NVIDIA 185.18.14 drivers again and Google Earth still works!

Which is nice... :D

P.S. I am now also able to start & play the game Flatout 1 again through Wine. The graphics-demo Tropics of the Unigine also works now.
Which is even nicer

ddufour
3rd July 2009, 01:13 AM
I had the signal 11 problem with googleearth also with Fedora 11. on a x86_64 with an nvidia card and the proprietary driver. I did:

yum install xorg-x11-drv-nvidia-libs.i586

and now googleearth work fine! :)

mandylion
17th July 2009, 05:46 PM
Thanks ddufour for your post.
I did the "yum install xorg-x11-drv-nvidia-libs.i586" on my
Fedora Core 11 on x86-64 and everything runs great now :)