PDA

View Full Version : yum problem - always 1 update available



den23513
13th June 2009, 09:29 AM
I always have notification about 1 update in the bar (update applet, red star)
When I trying to get the update, I get: "No packages marked for update"

yum clean all
yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
No Packages marked for Update

What wrong with the update applet? (FC11)

axet
13th June 2009, 12:25 PM
its applet bug, just login/logout

RahulSundaram
13th June 2009, 01:10 PM
Hi

Refer

http://fedoraproject.org/wiki/Common_F11_bugs#Update_notification_doesn.27t_disa ppear

den23513
13th June 2009, 03:28 PM
Thank you.

nickski
13th July 2009, 09:55 PM
I have had a similar problem. Mine keeps saying I have 208 updates available. This is a fresh F11 install. Every time i try to update, it says i have a network time out. When i try to update thru terminal, it keeps trying to find download mirrors for like 6 packages that have to be downloaded. Eventually it just gives up and tells me its error. I have over 200 updates downloaded, it just won't let me install them because it tries to download the ones it is missing. In the update manager, i disselected the the troublesome ones, but its still attempts to download them. I tried this bug fix, and it took away one update. So now i have 207. Please tell me i will not have to install every single package manually from terminal... :(

Edit: Finally got security updates to install, just still having trouble DLing these 6 packages.

den23513
14th July 2009, 01:00 PM
Its global updates problem..
Check this thread: http://forums.fedoraforum.org/showthread.php?t=226191

nickski
14th July 2009, 09:08 PM
Yea i eventually saw that shortly after. I am all updated now. thanks for responding tho

saqer
14th July 2009, 11:29 PM
Maybe these updates are still in the updates-testing repo. I have 6 packages that won't install with the annoying 404 not found error. These packages are dhclient, gdb, grubby, lftp, mkinitrd and nash. There might be more packages with the same problem that are not installed in my system to start with. Long story short is if you do

yum update "dhclient, gdb, grubby, lftp, mkinitrd nash" --enablerepo=updates-testing
They should install.

The weird thing is that in my x86_64 I did not have to do the --enablerepo=updates-testing thing because these packages are already pushed to updates. Only the i386 ones that are forgotten and left in updates-testing. I say weird because it's been days with this problem not solved.

nickski
15th July 2009, 04:36 AM
Yea, i just gave up and found links to all of the updates through my browser. Not easier, but hey, you gotta do what ya gotta do.