PDA

View Full Version : kernel crash allot



lhorace
12th June 2009, 09:51 PM
HI Everyone,

I'm having some/piticular problem(s) with my fresh install of Fedora 10.

My system specs:

Brand: Toshiba Sattilite
Processor: AMD Athlon X2 64 Bit
Video: ATI Radeon HD 3100 256MB DDR2
Memory: 2GB DDR2
HD: Partion 220GB Windows Vista Home Premium, 20GB Fedora 10 KDE 4.2.2, 2GB Swap

Clean Install, Full/All updates

Video Driver Latest: Fglrx from RPMFUSION

My system starts and I get the desktop, Pretty much everything works fine just for some minor bugs.

My problems lies with Logout and Dual Display and sometimes with Shutdown.

When I logout, I get this message
Failed to exec command "/tmp/fireglXXXXXX" (File no longer exists)<-- Something to the affect then Kernel Crashes

When I shutdown, I get rows of blinking X's with gray background from top to bottom of the screen then I see services pop out from the background stopping and the system shuts down successfully.

When I suspend to ram, it suspends to ram successfully, on occassion when I wake up, Kernel Crashes.

When I start the computer with the monitor plug in, starts up fine until Xorg boots and I get: Failed to exec command "/tmp/fireglXXXXXX" (File no longer exists), then Kernel Crashes.


All these kernel Crashes, Kernel debug trace runs and I boot the next time and I see the report.

Same report for all Kernel Crashes.

I'm not at my computer right now but error says

Kernel Crash Message 1:

BUG: Sleeping Atomic invalid context<-- something like that, as soon I get to my computer I post up here soon.

lhorace
12th June 2009, 10:37 PM
Here's my Kernel Trace output crashes, Please let me know if you need any more info, Thank Very much, help would be appreciated. I have tried googling but I'm not sure what google for, the error report blow produce search results for other problems with no solutiongs, thanx.


Kernel failure message 1:
BUG: sleeping function called from invalid context at kernel/rwsem.c:21
in_atomic():0, irqs_disabled():1
Pid: 2737, comm: sh Tainted: P D 2.6.27.24-170.2.68.fc10.x86_64 #1
Jun 11 22:06:08 horacepc kernel: Call Trace:


Kernel failure message 2:
general protection fault: 0000 [1] SMP
CPU 1
Modules linked in: sco bridge stp bnep l2cap bluetooth sunrpc ip6t_REJECT ip6t_ipv6header nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand powernow_k8 freq_table dm_multipath uinput snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event ata_generic snd_seq pata_acpi snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer i2c_piix4 snd_page_alloc i2c_core pata_atiixp uvcvideo snd_hwdep usb_storage snd r8169 pcspkr compat_ioctl32 video joydev arc4 ecb output videodev rfkill crypto_blkcipher v4l1_compat soundcore input_polldev mii fglrx(P) ath9k shpchp mac80211 battery ac cfg80211
Pid: 2737, comm: sh Tainted: P 2.6.27.24-170.2.68.fc10.x86_64 #1 Satellite L305D
RIP: 0010:[<ffffffff810bb1f2>] [<ffffffff810bb1f2>] __kmalloc+0x9a/0x10c
RSP: 0018:ffff88005acdbcf8 EFLAGS: 00010002
RAX: 0000000000000000 RBX: 0000ffff00001f80 RCX: 0000000000000008
RDX: ffff88000102ae50 RSI: 00000000000000d0 RDI: 0000000000000200
RBP: ffff88005acdbd28 R08: ffff880047473210 R09: ffff88005b5a3128
R10: ffff880047473210 R11: 000000b0006c4000 R12: ffffffff81559f70
R13: 0000000000000286 R14: 00000000000000d0 R15: ffffffff810f6324
FS: 00007f7a81f80750(0000) GS:ffff88006f804880(0000) knlGS:0000000000000000
CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 00000000006c32e4 CR3: 0000000060951000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process sh (pid: 2737, threadinfo ffff88005acda000, task ffff88004bcbdc40)
Stack: 0000020000000018 0000000000000188 0000000000000188 000000000000e988
00000000006c32e4 0000000000000000 ffff88005acdbe58 ffffffff810f6324
0000000000000020 ffff88005b5a30c0 ffff88005acdbf58 ffff8800608e7700
Call Trace:
[<ffffffff810f6324>] load_elf_binary+0x9fe/0x16c2
[<ffffffff810c467e>] ? get_arg_page+0x4b/0xab
[<ffffffff810c4abe>] search_binary_handler+0xcb/0x254
[<ffffffff810c5d77>] do_execve+0x1c3/0x275
[<ffffffff810ca8ae>] ? getname+0x16c/0x1d2
[<ffffffff8100e643>] sys_execve+0x3e/0x59
[<ffffffff810107ea>] stub_execve+0x6a/0xc0
Jun 11 22:06:08 horacepc kernel:
Code: 66 66 90 e8 65 22 fd ff 65 8b 04 25 24 00 00 00 48 98 49 8b 94 c4 f0 10 00 00 8b 7a 18 89 7d d4 48 8b 1a 48 85 db 74 0c 8b 42 14 <48> 8b 04 c3 48 89 02 eb 17 49 89 d0 4c 89 f9 83 ca ff 44 89 f6
RIP [<ffffffff810bb1f2>] __kmalloc+0x9a/0x10c
RSP <ffff88005acdbcf8>
---[ end trace 484c54f2b990c8d3 ]---

Here's my yum output for fglrx drivers



yum list kmod-fglrx fglrx

Installed Packages
kmod-fglrx.x86_64 9.3-1.fc10.4 installed

lhorace
13th June 2009, 01:10 AM
I think I might have norrowed it down to Exec failed for command "/tmp/firegl1.isse.5b5ab150.46aeeaef.000a048a" (No such file or directory) which has to do with fglrx..... Only solutions I find so for are for ubuntu...

lhorace
13th June 2009, 02:06 AM
any help, The main reason I'm using linux is for Dual Monitor, In windows vista, the driver stops responding after few minutes of use, I thought I would be better off using linux, I reinstalled driver and kernel few times, reinstall fedora and the problem reappears, I'm not sure if I should install the driver from ATI website...

lhorace
14th June 2009, 08:48 PM
I know it's only been I couple of days, but I couldn't wait any longer and I decided to install Kubuntu 9.04 and everything works flawlessly... Suspend to ram with no kernel crashes, logout with no kernel crashes, ati driver installed successfully and I have full 3d acceleration...

I usually got 546 fps using the glxgears with desktop kde affects under fedora 10 with full updates, under Kubuntu I get 1200 fps with desktop effects all the way up to 1400 fps... i'm sorry fedora, you looked very promising but still not there for an average desktop user,

lhorace
14th June 2009, 08:50 PM
On possitive note AMD64, fedora 10/kubuntu, firefox is blazzing fast!!! faster then on windows vista pc, I mean loading time is faster, fast fast fast, fire 3.0.11 you rule...