View Full Version : Odd VirtualBox issue with upgrades and rpms

6th June 2009, 04:20 AM
I'm not asking for help here, because I haven't been able to duplicate this issue on a second machine, just putting out there to see if anyone has run into anything similar.

I have a workstation that was running F10. VBox always worked quite well. At some point, I put in VMware server 2.0 as well, but I don't believe that was a factor. I would only run one at a time and was always careful to make sure that neither started from services.

It's a 64 bit system, but a low end one, and the processor doesn't have the VM flags, so all guests are 32 bit.

Also, the timing isn't quite right for VMware to have been the issue.

I was cheerfully running 2.1.0. I upgraded to 2.2.0 and at the same time, decided to reinstall the various VMs that I had.

All installations were painfully slow, including freezes with some of them. For example, with CentOS, if I used the GUI installer, it would simply freeze at some point. Going back to 2.1.0 didn't fix it, even after making an effort to rid myself of all older libs and all files I could find.

For this and other reasons, I decided it was time to completely redo my workstation, so I put F11 on it. I did a fresh install of Vbox 2.2.0. It worked well for a few days, but this was also before I'd installed a few things. Then, I upgraded to 2.2. 24 when it came out. It started freezing again, and doing a new CentOS install, ran into the same type of thing, freezing during install if I ran GUI mode, taking forever with text mode, and then, after installation, being incredibly slow, including text mode.
Downgrading again, didn't help.

So, once again, uninstalled everything. Installed VMware server 2 again, and it was working quite well, surprising me, actually, as I'd not remembered it doing so well. Still, I find VBox easier, no need to open a web browser to start things, etc.

Soooo, as a last resort, rather than using the Fedora rpms (I'd used the F9/F10 one for F10 and the new F11 one for the new installation) I just downloaded the shell script that is for all versions. That one, so far, seems to be working like a charm.

I repeat, this has only been on one, rather lowend machine. It's also the only Fedora machine I have running Vbox, my other machine with VBox is my home CentOS server/workstation, with a quad core processor, (with the VM flags) and 4 GB of RAM, vs 1500 on the workstation.

My question is more one of idle curiosity, if anyone has run into something similar. I saw a somewhat unrelated bug of theirs, with Ubuntu as the host and a Windows guest, but although the symptoms were slightly similar (bad performance, freezing) it seemed to be related to some MS apps.

Thanks for any input. Note that unless this installation starts getting bad as well, I won't be able to test any suggestions, as this is a work machine and I need the VMs for testing various things, so I'm not asking for help. I"m more curious if anyone has gone through anything similar, especially with rpm vs. the generalized .run install program.

6th June 2009, 05:27 AM
Not quite like that, but I did have some issues with Vbox - I always run the Sun version, not the OSS (USB-less) version from Fedora repos. My hardware sounds very smilar to yours (F10 x86_64 without virtualisation hardware support, so guests are 32-bit).

2.1.2 worked fine. When I upgraded to 2.1.4, my main guest wouldn't start at all. A further upgrade to 2.2.0 made it work again but now it's very sensitive to CPU utilisation - if I do too much in the guest, it max's out the CPU, freezes and doesn't recover (whereas, in 2.1.2 and earlier it would eventually recover and was far less sensitive to load). As a result, it's almost useless to me. I've yet to upgrade to 2.2.4, so that may fix it.

Still, it's been on my list of things to do to get a faster machine (this one is almost 5 years old).

6th June 2009, 05:50 AM
If you feel adventurous, try downloading the one size fits all 64 bit version and see if you have better luck. If you do, then I think we're on to something. :)

Glad to hear it's not just me. I should add that
I always use the non-free version (actually, didn't know the other version was in the repos, but on occasion, I want the USB stuff, so it doesn't matter.)

Thanks for the post.