PDA

View Full Version : gdesklet = won't load display



krazibon3
15th September 2004, 06:49 PM
Heyas i'm just trying to get gdesklets to load a few displays that i want running on my computer. I'm currently trying to get psii-small to work on my computer. I've downloaded and installed the sensors and managed to get the daemon running. When i type "gdesklets open networkinfo.display" or any other display i get the same error message:



raceback (most recent call last):
File "/usr/local/share/gdesklets/factory/SensorFactory.py", line 75, in create_sensor
sensor = module.new_sensor(args)
File "./Theme/__init__.py", line 112, in new_sensor
def new_sensor(args): return apply(Theme, args)
File "./Theme/__init__.py", line 31, in __init__
for a in output[0].split():
IndexError: list index out of rang


Then another window would pop up giving this message:



Invalid display file '/home/mike/.gdesklets/Displays/diskinfo.display'

The display file contains invalid data and could not be loaded.


I'm using KDE on FC2, any help or suggestions would be appreciated. I've looked through the gdesklets thread but couldn't find a similar problem to mine.

desipher
15th September 2004, 07:18 PM
this might help http://www.fedoraforum.org/forum/showthread.php?t=20856&highlight=gdesklets

imdeemvp
15th September 2004, 07:24 PM
and make sure you dont skip this 2 threads from the link above:

http://www.fedoraforum.org/forum/showpost.php?p=97546&postcount=11

krazibon3
18th September 2004, 01:09 PM
By going through the forums at gnome i semi solved the problem by following rafaels instructions located on this link for those who are interested:

http://gnomesupport.org/forums/viewtopic.php?t=5284&postdays=0&postorder=asc&start=135

Additional note: If you can't get the desklets to load move your displays and sensors into your directory ~/.gdesklets/Sensors (you might have to create the directory Sensors) and then try loading the displays.

i managed to get psi displays working, but i couldn't get the psi HD desklets to work.

This is for gdesklets 0.30 compiled from a tarball not an rpm.

imdeemvp
18th September 2004, 07:36 PM
great info...this will be useful :D

MikeyMike
19th October 2004, 09:30 PM
so did u get it to work? cause im havin the same prob

imdeemvp
19th October 2004, 09:33 PM
so did u get it to work? cause im havin the same prob
did you read my post and the threads i re-directed the users to?

MikeyMike
20th October 2004, 12:24 AM
did you read my post and the threads i re-directed the users to?

o i didnt even see ur post thanks for the info im gonna get right on it