View Full Version : ssh in Fedora 10 doesn't work with a Ubuntu server

8th May 2009, 11:40 AM

I've recently updated to Fedora 10, and found out that ssh doesn't work with a Ubuntu server. When I tried to ssh the server, the connection is closed. Is there anyone who can help me on this? Thanks.

I'm sure that server is all right. I can ssh to other machines, and then ssh to that server. I even could ssh from that server to my local machine. However, once I tried to ssh that server, the connection could not be setup.

I've already tried install openssh to the latest version manually, and closed the SElinux. Nothing works.

Here is the log:

~]$ ssh 128.138.*.* -v
OpenSSH_5.2p1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /usr/local/etc/ssh_config
debug1: Connecting to 128.138.*.* [128.138.*.*] port 22.
debug1: Connection established.
debug1: identity file /home/lizheng/.ssh/identity type -1
debug1: identity file /home/lizheng/.ssh/id_rsa type -1
debug1: identity file /home/lizheng/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.7p1 Debian-8ubuntu1.2
debug1: match: OpenSSH_4.7p1 Debian-8ubuntu1.2 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '128.138.*.*' is known and matches the RSA host key.
debug1: Found key in /home/lizheng/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
Connection closed by 128.138.*.*

Thanks a lot!!