PDA

View Full Version : eclipse 3.0 and fedora core 2



arupsarkar
13th September 2004, 04:46 PM
Hi,

I have installed fedora core 2 and downloaded eclipse stable build 3.0. Unzipped it but when I am executing the command ./eclipse from the installed directory I am getting an error.

NOTE : I have already JAVA_HOME in my .bash_profile and put it in my path.

Can anybody please tell me what I am missing.

Regards

ewdi
13th September 2004, 04:48 PM
what is the error message?

arupsarkar
13th September 2004, 07:40 PM
The following is the error message :

!SESSION Mon Sep 13 11:58:15 EDT 2004
------------------------------------------!ENTRY
org.eclipse.core.launcher 4 0 Sep 13, 2004
11:58:16.160
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.RuntimeException: Could not find framework
at
org.eclipse.core.launcher.Main.getBootPath(Main.ja va:355)
at
org.eclipse.core.launcher.Main.basicRun(Main.java: 172)
at
org.eclipse.core.launcher.Main.run(Main.java:644)
at
org.eclipse.core.launcher.Main.main(Main.java:628)

ewdi
13th September 2004, 07:45 PM
try put JAVA in global instead of profile
let me know if it work

arupsarkar
13th September 2004, 08:14 PM
I added the JAVA_HOME in /etc/profile and did a export JAVA_HOME/bin. I am getting the same error.

Have I done it right ?

arupsarkar
13th September 2004, 08:22 PM
It has been fixed...Thanks for your help !!! The problem was that the downloaded zip file was not extracted properly...

Thanks Again !!!

ewdi
13th September 2004, 08:31 PM
glad it works :)

jcstille
14th September 2004, 02:29 AM
Yeah being a java programmer your packages were not place correctly.

m3rlin
24th October 2004, 09:02 PM
hello everyone,
I'm trying to use Eclipse 3.0.1 with jdk 1.5.0, because I'm required to use the Scanner class. I set the the path in Linux Fedora Core 2 so I can start eclipse from the terminal everything seems to work normal. But everytime I try to import java.util.Scanner; I get this message "The import of java.util.Scanner cannot be resolved." or when I import java.util.*; the message is "The import java.util is never used" please, if you're able to help me, tell me what to do. thank you very much
this is the first time when I'm writing on a forum and maybe I did not read the rules too carefully...

crackers
25th October 2004, 03:44 AM
Eclipse 3.0.1 won't work with Java 5 - the parser's are not set to handle it, especially generics and enums. Use Netbeans 4 (beta) instead - it's gotten a lot better, even though it's still not quite up to the level of sophistication in Eclipse and IDEA.