PDA

View Full Version : If your sounds doesn't work try this!



clearer
13th September 2004, 04:09 PM
I have had problems with sound on three different soundcard - first I thought that my cards simply didn't work with FC2-x86_64, this seemed even more so, when I updated and sound suddently worked.
I later found (after a reinstall) that the sound problems had nothing to do with drivers but with volume. If it seems like your sound isn't working it might simply be that your volume is too low.
Start up your favourite volume control programme and check it. One that is able to handle more than one channel for output is preferable (though I can't seem to think of one that can't) - I found that my onboard card didn't respond to changes in the master volume, but only to individual channel changes (not left/right, but front/rear/center channels).

If this has already been covered somewhere, I'm sorry. I did a search but couldn't find anything that seemed like it was adressing this issue right away.

EDIT: I must remember to inform you that I placed this article here, because I have not had any problems like this on the 32-bit version - it seems to me like it's a 64-bit problem.

ShadowChaser
13th September 2004, 04:59 PM
Thanks for the Info,,
-SC

Dog-One
21st September 2004, 02:34 AM
I found this out too.

Have you found a way to make the volume settings stick after you set them?

superbnerd
21st September 2004, 02:41 AM
this is what I have in my /etc/modprobe.conf regarding my sound card. the install and remove part is what keeps your volume settings
alias snd-card-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
just substitute "intel8x0: with the name of your sound card. you can find the name using the hardware browser under system tools.

Dog-One
23rd September 2004, 04:22 AM
That's what I have in my modprobe.conf file. I think it was put there by kudzu. And still when I reboot, I have to push all the mixer settings back up.

I see what's happening. Alsactl saves and restores the mixer settings based on the loading and unloading of the sound driver module. Since the sound driver module never actually gets unloaded during a reboot, it never saves the values. The trick is to do a "alsactl store" after you change the mixer settings and then when you reboot, they'll come back as you last saved them.

HTH

superbnerd
23rd September 2004, 04:33 AM
try updating again becuase your problem is a know problem with gnome and it was fixed in fc2_32bit I believe.