PDA

View Full Version : psyco in fedora 9



timcoote
28th April 2009, 02:04 PM
for some odd reason, there doesn't seem to be a psyco in f9. Am I missing something? python-psyco is in both f8 and f10.

glennzo
29th April 2009, 10:50 AM
It is available for Fedora 9.

[eric@slowhand ~]$ yum list python-psyco
Loaded plugins: fastestmirror, presto, refresh-packagekit
Setting up and reading Presto delta metadata
No Presto metadata available for rpmfusion-free-updates
No Presto metadata available for rpmfusion-nonfree-updates
No Presto metadata available for rpmfusion-free
No Presto metadata available for updates-newkey
No Presto metadata available for rpmfusion-nonfree
No Presto metadata available for repof9
No Presto metadata available for updates
Excluding Packages in global exclude list
Finished
Available Packages
python-psyco.i386 1.6-1.fc9 updates-newkey

timcoote
29th April 2009, 11:17 AM
bizarre. I'm sure that I couldn't find it here:

https://admin.fedoraproject.org/pkgdb/collections/id/15?tg_paginate_limit=0
yesterday. Probably finger trouble on my part.

In any case:

[tim@venus ~]$ cat /etc/redhat-release
Fedora release 9 (Sulphur)
[tim@venus ~]$ yum list python-psyco
Loaded plugins: refresh-packagekit
Error: No matching Packages to list
[tim@venus ~]$ yum list |grep -i psyco
python-psycopg.x86_64 1.1.21-7.fc9 fedora
python-psycopg2.x86_64 2.0.10-1.fc9 updates-newkey
python-psycopg2-doc.x86_64 2.0.10-1.fc9 updates-newkey


Is this possibly an issue with 64 bit? I know that psyco's not supposed to work on 64bit architectures. I'd guess that I'm going to have a challenge getting the 32 bit psyco to work on 64bit, probably needing a complete shadow python installation.

aleph
29th April 2009, 12:10 PM
Psyco doesn't work with x86-64 and I don't believe the 32-bit version could bring the boost in performance in a 64-bit install.