View Full Version : yum version mismatch :S

17th April 2009, 09:50 AM
okay so i installed F11 from an Alpha live disk I had laying around, installation went perfect, rebooted, installed my wireless firmware rebooted and was on the net. "yum update" then "yum --skip-broken update" because of dependency problems (no dramas) it went away downloading the 500M of updates and started installing. All (or atleast all the installs i saw ) were coming up with a checksum error, so i CTRL+C to try and stop the checksum check (now i realise i was thinking about the gpg signature check...) but whenever i try and call yum i get the following out put:
[root@localhost aaron]# yum update rpm
Loaded plugins: dellsysidplugin2, refresh-packagekit
rpmdb: Program version 4.7 doesn't match environment version 4.5
error: db4 error(-30971) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db3 - (-30971)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 299, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 153, in main
File "/usr/share/yum-cli/cli.py", line 188, in getOptionsConfig
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 630, in <lambda>
conf = property(fget=lambda self: self._getConfig(),
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 227, in _getConfig
self._conf = config.readMainConfig(startupconf)
File "/usr/lib/python2.6/site-packages/yum/config.py", line 772, in readMainConfig
yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
File "/usr/lib/python2.6/site-packages/yum/config.py", line 842, in _getsysver
idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

obviously yum partially updated before i killed the process, but i was just wondering if there is any chance i can save my system or if i'd be best just to find/buy another cd to install beta? (we have non left in the house and a live usb didnt work, are there any other ways of installing?)

I have numerous copies of F10 install dvd's, a F10 Updates DVD (13-Mar-09) and various Ubuntu/openSUSE/linux install/live cd/dvds if they would help?
i tried installing the yum*.rpm from the updates dvd but with yum being broken it didnt like it...

Many thanks in advance :)

17th April 2009, 10:25 AM
Good day MrHappyPants. Isn't this one of those cases where it's time for these commands?
yum clean all
rm -f /var/lib/rpm/__db*
rpm --rebuilddb
yum update

17th April 2009, 11:03 AM
wow you're a legend :)
had do CTRL+ALT+F2 into init 3 because terminal wouldn't start, but it seems to be working.
This time I shall let the transaction complete, none of this impatience.... :$

Thank you kindly!

17th April 2009, 11:14 AM
You're very welcome. I've been called many things, in real life and on these web forums, but never a legend. Gee, thanks. :p Glad to see that it appears to be working now. In all honesty, my answer to your question was somewhat of a stab in the dark. I wasn't quite sure if the advice was 100% accurate, but I've seen this sort of question many times here, especially with Fedora 10. That's why I worded it the way I did, hoping that you would do a little research before trying it so that you'd know for sure that this was the right move.

I love this yum program (one of my favorites) and all that it offers, but it has been somewhat of a thorn in the side of all Fedora users since it's inception. One problem after another it seems, although for the most part it just works. It has been one of the features of Fedora that I've tried to stay on top of, so I keep notes on how to use the program to it's fullest and how to get around some of the little glitches that seem to keep popping up.

17th April 2009, 11:25 AM
I only started toying with linux (started with ubuntu for about a week, then fedora and have dual booted with a variety of others) from febuary this year so i'm not too up with it (and don't know of yum's predecessor)
I'm trying to learn as fast as I can, but always gracious for tips/tricks :)

17th April 2009, 11:42 AM
You're in the right place if you want to learn about Fedora, and Linux in general for that matter. There are about a gazillion threads here about yum. Cool tool but prone to breakage it seems. There is a graphical front end for yum. It's called yumex. To install it issue sudo yum install yumex. When the installation is complete you'll find a menu entry under Applications > System Tools > Yum Extender. Nice option for those who don't care for the command line.

17th April 2009, 11:48 AM
yeah I tried yumex a while ago on my old system but I found it a little confusing and am content with the command-line. I've just started a job where we're running linux/unix/irix in all sorts of forms so learning my way around the terminal has been (almost shamefully) fun (Y)

17th April 2009, 11:55 AM
I enjoy the command line stuff and would prefer to use it over the graphical tools. In your case, learning the command line would seem fairly mandatory if you're dealing with multiple Unix like OS's.

17th April 2009, 12:09 PM
Its more involved and also easier than slaving away to the mouse.
I was just browsing the forums and stumbled over your thread on converting your son to Linux. My girlfriend was intrigued with what had become so involving of me the last few months that she asked kindly for a dual boot once realising you could have windows AND Linux!!!!! haha she, however, gave up after about a week, even though I'd set up .docx support in open office and went through days trying to hack into their wireless before her mum realised "the computer man" had written down all the info on a piece of paper :S

[UPDATE ON YUM]: So far at 450 installed, I've had a handful of "/path/to/xyz created as different/path/xyz.rpmnew" so nothing to worry about! Rather pleasing too, I don't think dad would be too happy with ANOTHER half a gig downloads... (the joys of living at home:))

23rd April 2009, 03:59 PM
Just to post a thank you, i was having GPG key issues after an upgrade from Fedora 10 and removing and rebuilding the RPM database fixed everything.

23rd April 2009, 04:39 PM
...(and don't know of yum's predecessor)...

yum's predecessor was spending hours trying to resolve all of the dependencies for the package you're trying to install. :D

24th April 2009, 01:36 PM
yum's predecessor was spending hours trying to resolve all of the dependencies for the package you're trying to install. :D

That sounds... fun? I didn't really miss anything then I guess. Although, after tasting the freedom of linux (both free as in beer and free as in freedom) I don't think I'd ever be able to go back to windoze. I wish I'd made the switch sooner...