PDA

View Full Version : Another font problem



BenTrein
11th April 2009, 07:54 AM
I installed a lot (3000+) ttf fonts with a script I found on this forum. It worked great, and GIMP shows all fonts correctly. Only Open Office is trouble-some. Times New Roman is displayed incorrectly (it's the same as Black Knight). If it was any other font that had gone crazy, I wouldn't have complained. But this font is rather commonly used...
Does anyone have any suggestions how to get it working properly again?

PatMcLJr
11th April 2009, 03:09 PM
I don't know.
3000 fonts is quite a few and I would suggest a more managed approach with that many fonts.
I like to have my "core" fonts and then add in or out the ones I what for a project.
You don't have to copy them over to a directory you can have in one place and then symlink them to
~/.fonts
and that give you access to them.

Best of Luck,
Pat Jr.

BenTrein
15th April 2009, 07:31 AM
While I understand the basics of what you are saying, I haven't managed to fix it... I tried several things, but it's not working out.

To install the fonts, I used this script (http://forums.fedoraforum.org/showthread.php?t=164127)

Can someone please help me undo this? Which files do I need to edit? As you may see in my sig, I'm an amateur writer, and Times New Roman is my easiest font. I kinda need it! :)

BenTrein
15th April 2009, 12:14 PM
Let me perhaps make it simpler to answer. That script I talked about in my previous post, moves the ttf files to a certain directory, and directs fedora to include that folder when sorting fonts... Which files do I need to edit to take that folder out of the fonts list?

Please help! I've already tried removing all the fonts from that folder. Upon reboot I got a Kernell error, which I let Fedora fix automatically. All is well now, except that Open Office still doesn't display Times New Roman properly.

BenTrein
16th April 2009, 02:38 AM
Problem solved.

Call me a noob, but I didn't realize that yum could also remove fonts. Manually did that (too many; had to reinstall gimp, and some other things), then reinstalled only the mtts core fonts, and guess what, it works.