View Full Version : NetworkManager applet requests keyring password

11th April 2009, 12:51 AM
I have a FC10 installation with GNOME and NetworkManager and a wireless card. Everything works ok. However, when I try and setup gdm to do autologon I get the NetworkManager applet asking for the password for the gnome-keyring to get the wireless details. Since I want to use this machine as a sever this is unacceptable as I won't be around to type in the password. I tried the solution at http://fedoraproject.org/wiki/Tools/NetworkManager but this does not work. I still get the password being requested and the keyring password is the same as the logon password.

Can anyone say if there is a workaround that works to get the NetworkManager to be able to read the gnome keyring without having to prompt me for it.


11th April 2009, 02:49 PM
OK. I found a workaround. in cnetworkmanager http://repo.or.cz/w/cnetworkmanager.git. This allows a command line interface to NetworkManager.

I downloaded the tar and unpacked it and did:
make install

which installed it into /usr/local/bin. Then I wrote a one line script:

/usr/local/bin/cnetworkmanager -C <connection point> --wpa-pass <wpa pass phrase>

and added this to the session startup programs via Preferences -> Personal -> Sessions, as well as disabling the NetworkManager startup program. So now when I autologon via editing /etc/gdm/custom.conf I have a valid wifi network link.

I don't have any applet that indicates the current status of the connection but I can live with that for now, till the keyring stuff is sorted out.


11th April 2009, 03:31 PM
you can remove the keyring password by deleting the keyring file in ~/.gnome2/keyrings/

Then next time it asks, enter nothing, it'll warn you that this is unsafe, ignore that crap and proceed, then you'll have a keyringless NetworkManager :)

11th April 2009, 03:45 PM
On my laptop I had the same problem. I went into /home/.gnome2/keyring (something like that) and deleted the keyring.default file. Then on reboot it wanted me to setup a keyring password. I entered without a password and it asked me if I wanted to use unsafe storage and I entered yes. Now it doesn't ask me any more, it just starts the wireless on login.

Of course the wep key is now stored unencrypted. I am not overly concerned but maybe I should be(?). Anybody that can sit at the laptop can get to the key now. But its just us at home here and they don't know what gnome is much less keyring. Maybe someone can comment on how big a security issue this is. I guess the physical security of your hardware would be a factor. And if you store anything else in the keyring file.

And I figure that if they crack in from outside, they already know it - right! But the mac address filtering should thwart the attempt.

Proceed at your own risk....

I see someone posted the same thing as I was posting - cool.

11th April 2009, 03:49 PM
Unless you work for the fbi I really wouldn't worry about this.

11th April 2009, 04:02 PM
LOL! I guess I'm good-to-go then.