PDA

View Full Version : Cannot mount internal file systems



willyb1946
9th April 2009, 08:45 PM
I have F11 Beta successfully installed and fully updated in a multi-boot environment on a system with two internal SATA drives. Everything seems to be working OK except that I am unable to dynamically mount any of the partitions on the two internal drives. They are all listed under Places->Removable Media, but when I select one to view, I get a pop-up error box titled "Unable to mount <System Label>" with the following error text

org.freedesktop.devicekit.disks.filesystem-mount-system-internal auth_admin
I also have partitions on an external USB SATA hard drive, but these mount with no problems.

In Fedora 10, which is one of my other multi-booted systems, when I do the same thing, the internal partitions are dynamically mounted when selected and I can see the contents. In both systems, I have not added any entries to fstab, but allowed the system to mount dynamically.

I am sure the problem is some obscure authorization setting somewhere, but I am a relative noob at this security stuff and I would appreciate any help getting this solved.

Any ideas guys?

AdamW
9th April 2009, 10:18 PM
That's PolicyKit sticking its nose in. Is this KDE or GNOME?

willyb1946
9th April 2009, 10:30 PM
It's Gnome.

AdamW
14th April 2009, 05:35 PM
Actually, I saw the same issue just after posting to this thread. An upgrade and reboot fixed it for me.

willyb1946
14th April 2009, 05:53 PM
You're right. I found the same thing last Friday after installing 118 package updates. Something in there corrected the offending policy. Just out of curiosity, I navigated to the policy in PolicyKit using the info in the error message and checked out the setting that was changed. I had been prepared to make the change myself but didn't have to. I guess this problem solved itself. :D