View Full Version : LiveCD wireless works fine, installed not so much

7th April 2009, 01:15 AM
i can run the LiveCD just fine, and connect to my WLAN with no problem. Encouraged, i went to install to hdd. After reboot to said hdd, suddenly the wireless won't connect anymore.

i'm on a Gateway FX series notebook. During the LiveCD > hdd transfer, there have been a few hiccups, some nondescript warnings asking me to submit them to kerneloops.org, but installation continues, and there doesn't appear to be anything else broken after install.

i'm downloading the DVD now to see if i get any better luck there. i'm not an expert, but i can get around ok with clear instruction. i just wanted to take Fedora for a spin on my new lappy and see if a complete switch wouldn't leave me with such a bitter taste in my mouth as prior attempts on other machines (with Fedora, Suse, etc).

7th April 2009, 02:40 PM
Do you use intel wireless?

In that case, try a 'rmmod iwlagn' then a 'modprobe iwlagn' (if it doesn't work first time try again)

then it should work, a little bug with the beta, after a yum update (--skip-broken ofc this is rawhide ) it will work properly.. :)

8th April 2009, 03:46 AM
Thanks for the assist bsund.

Wireless is working. :D Yay.

However, i can't seem to get yum working because the LiveCD doesn't install any repositories. i attempted an install from DVD, but that installer requires a hard-line network connection.

Just can't seem to win. Any idea if final will detect/support WiFi installation?

In the mean time, where can i get the repos for yum?

8th April 2009, 04:28 AM
Scratch that, at least for now. Found the software updater/manager in the menu. D'oh.

24th May 2009, 08:40 AM
Sorry to revive this problem, but it has returned. i installed the preview of F11 from LiveCD (DVD still doesn't install clean on my laptop), and wireless will not connect.

i can create the connection entry from the NetworkManager Applet, and the network monitor pretends to get an IP, but i can't go anywhere.

i did find that my wireless hardware is not activated (Administratiin > Network Configuration, Devices), but can't find ANY way to activate it. The Activate/Deactivate buttons are disabled.

i've been into Administration > Network Device Control, and after granting permission for all users to access the network controls, wlan0 disappeared from the list. i created a new entry under Network Configuration from the wizard. That entry shows up under NDC, but when i try to activate it, it fails.

i've tried rmmod iwlagn / modprobe iwlagn. That only tells me that the config file is deprecated. "all config files belong to modprobe.d". Which has blacklist, dist, and floppy conf files. Not very useful.

i'm frustrated by the counter-intuitive control structure for wireless, and how buggy it still seems to be. i'm trying really hard not to go on a tirade of how complicated Linux still is, so any help would be greatly appreciated.

24th May 2009, 10:23 AM

24th May 2009, 10:29 AM
Hello cautionbug

Using (Administratiin > Network Configuration, Devices), or any of the methods off the menu system are not easy to control wireless. The default method in Fedora is through NetworkManager which lives in the system tray area of panel in both Gnome and KDE.

While it is running it will actively prevent any other method from controlling the card. If we are going to progress here with your wireless, I would recommend that you undo any configuration changes you have made to give NetworkManager the best chance.

I think we then need to know which version of Fedora you are running and just what chipset is in your wireless device.

Run the command:


and post back the part that relates to your card along with the Fedora version and we'll see if anyone has any experience of a similar problem.

EDIT: Forget the part about which version, I've just realised which section of the forum we are in!

24th May 2009, 05:28 PM
Thanks to both of you for the responses. i took bbfuller's suggestion and reset my config (re-installed, i hadn't gotten very far anyway). Using only Network Manager, i connected to my hidden SSID and got an IP address. i could ping stuff, but not get any http traffic.

Then it dawned on me that i would probably need to manually assign the DNS entries from my DSL modem into the connection settings in NM. NM was automatically taking the router's DNS setting, which is the address of the DSL modem.

Switched to DHCP (address only), set the DNS servers, and i'm online.

Thanks again.