PDA

View Full Version : kernel-2.6.29.1-52 problem



robghealey
6th April 2009, 09:51 PM
Greetings:

My Fedora Core 11 machine was ully updated as of last night. I go to update it today, and I receive these errors.....

Resolving Dependencies
--> Running transaction check
---> Package libdrm.i586 0:2.4.5-4.fc11 set to be updated
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package: libdrm
---> Package libdrm-devel.i586 0:2.4.5-4.fc11 set to be updated
---> Package xorg-x11-drv-ati.i586 0:6.12.1-5.fc11 set to be updated
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package: xorg-x11-drv-ati
--> Finished Dependency Resolution
libdrm-2.4.5-4.fc11.i586 from rawhide has depsolving problems
--> Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package libdrm-2.4.5-4.fc11.i586 (rawhide)
xorg-x11-drv-ati-6.12.1-5.fc11.i586 from rawhide has depsolving problems
--> Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (rawhide)
Error: Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package libdrm-2.4.5-4.fc11.i586 (rawhide)
Error: Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (rawhide)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest


Yum is looking for and needs the kernel-2.6.29.1-52*, what is happening? Has anyone else had this same problem!!!

glennzo
6th April 2009, 10:35 PM
I just experienced the same thing. My method of attack will be to do nothing until kernel-2.6.29.1-52 is available :) No big deal. It will be along sometime in the near future. Here's some useless dribble. Looks to be the same as yours.

[glenn@laptopbeta ~]$ sudo yum update
Password:
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.i586 1:0.7.0.100-1.fc11 set to be updated
---> Package NetworkManager-glib.i586 1:0.7.0.100-1.fc11 set to be updated
---> Package NetworkManager-gnome.i586 1:0.7.0.100-1.fc11 set to be updated
---> Package compiz.i586 0:0.7.8-18.fc11 set to be updated
---> Package compiz-gnome.i586 0:0.7.8-18.fc11 set to be updated
---> Package control-center.i586 1:2.26.0-2.fc11 set to be updated
---> Package control-center-filesystem.i586 1:2.26.0-2.fc11 set to be updated
---> Package gdb.i586 0:6.8.50.20090302-15.fc11 set to be updated
---> Package gnome-session.i586 0:2.26.0-2.fc11 set to be updated
---> Package gnome-session-xsession.i586 0:2.26.0-2.fc11 set to be updated
---> Package gnome-user-share.i586 0:2.26.0-2.fc11 set to be updated
---> Package libdrm.i586 0:2.4.5-4.fc11 set to be updated
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package: libdrm
---> Package linuxwacom.i586 0:0.8.2.2-11.fc11 set to be updated
---> Package m17n-contrib.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-assamese.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-bengali.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-gujarati.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-hindi.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-kannada.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-malayalam.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-marathi.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-oriya.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-punjabi.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-sinhala.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-tamil.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-telugu.noarch 0:1.1.9-3.fc11 set to be updated
---> Package m17n-contrib-urdu.noarch 0:1.1.9-3.fc11 set to be updated
---> Package setools-console.i586 0:3.3.5-8.fc11 set to be updated
---> Package setools-libs.i586 0:3.3.5-8.fc11 set to be updated
---> Package tomboy.i586 0:0.14.0-2.fc11 set to be updated
---> Package xorg-x11-drv-ati.i586 0:6.12.1-5.fc11 set to be updated
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package: xorg-x11-drv-ati
---> Package xorg-x11-drv-evdev.i586 0:2.2.1-2.fc11 set to be updated
--> Finished Dependency Resolution
libdrm-2.4.5-4.fc11.i586 from rawhide has depsolving problems
--> Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package libdrm-2.4.5-4.fc11.i586 (rawhide)
xorg-x11-drv-ati-6.12.1-5.fc11.i586 from rawhide has depsolving problems
--> Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (rawhide)
Error: Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package libdrm-2.4.5-4.fc11.i586 (rawhide)
Error: Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (rawhide)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

And this tells me that the kernel isn't available yet.

[glenn@laptopbeta ~]$ yum list kernel*
Loaded plugins: refresh-packagekit
Installed Packages
kernel-PAE.i686 2.6.29-0.258.2.3.rc8.git2.fc11 installed
kernel-PAE.i686 2.6.29.1-46.fc11 installed
kernel-firmware.noarch 2.6.29.1-46.fc11 installed
kerneloops.i586 0.12-4.fc11 installed
Available Packages
kernel.i586 2.6.29.1-46.fc11 rawhide
kernel-PAE-devel.i686 2.6.29.1-46.fc11 rawhide
kernel-PAEdebug.i686 2.6.29.1-46.fc11 rawhide
kernel-PAEdebug-devel.i686 2.6.29.1-46.fc11 rawhide
kernel-devel.i586 2.6.29.1-46.fc11 rawhide
kernel-doc.noarch 2.6.29.1-46.fc11 rawhide
kernel-headers.i586 2.6.29.1-46.fc11 rawhide

So, I'm just going to wait it out and check from time to time to see if the kernel is ready.

mcmackin
6th April 2009, 10:48 PM
I see the same errors as of today. I'm sure a kernel is right around the corner. It might be available via koji...

SlowJet
6th April 2009, 10:49 PM
The rawhide updates report clearly shows the packages that made it into rawhide.
The start time (at the top) of the build was after the the kernel 52.and a second compile of ati drv.
The libdrm and ati drv had changes that are dependent on the kernel changes, so the kernel 52 is required as a minimal version. (rebooting into an older kernel wil not work after these updates.

Those reports should be checked before even doing an update.

SJ

robghealey
6th April 2009, 11:19 PM
Thanks for everyone who has made a comment here. I appreciate it and I will wait as well!

SjJ: did you say not to reboot the machine after these downloads because the older kernel will not work? I did not install libdrm* xorg-x11-drv-ati because yum would not do dependency resolution. Am I ok?

Thank you for the advance information!

SlowJet
6th April 2009, 11:27 PM
After the updates, the older kernel will not use the gui, so if there is a problem after the updates
you will need to
1. Wait utill a fix comes and/or
2. boot into the older kernel with 3 and update or downdate as needed. Then reboot to get the gui.
3. repeatt as needed from day to day to day ......... pre-release.

SJ

glennzo
6th April 2009, 11:33 PM
Bottom line is just wait. There's no hurry to update and remember that this is Beta, so expect things to be "broken" from time to time.

SlowJet
6th April 2009, 11:43 PM
Or he could get them off http:/koji.fedoraproject.org/koji
and test the newest ati+1 and drm.with kernel 52

I would. It's fun.

SJ

phoenixpb
7th April 2009, 08:26 AM
just installed kernel 52 with drm and ati
all work perfectly :)

try it no problem :)

Phoenix

glennzo
8th April 2009, 03:12 AM
Just got home from work. The kernel (kernel-2.6.29.1-52.fc11) is available now so I'm currently updating.