PDA

View Full Version : Window effects with nVidia driver



blaker1990
6th April 2009, 06:57 PM
Since installing the 64-bit nVidia driver for my 9800 gtx, I can't enable desktop effects because:
"Compositing is not supported on your system.
Required X extensions (XComposite and XDamage) are not available"

Is there any way around this?

JohnVV
6th April 2009, 08:24 PM
what driver did you install and DID you fallow the how to ?
" F10 & F9 Nvidia driver guides"
http://forums.fedoraforum.org/showthread.php?t=204752

blaker1990
7th April 2009, 12:40 AM
I installed the latest Linux driver from the nVidia site

JohnVV
7th April 2009, 12:54 AM
from the how to
did you add these lines to your xorg.conf??


Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules/drivers"
ModulePath "/usr/lib64/xorg/modules"
EndSection

ps if you installed the .run driver then the above lines DO NEED to be a bit different


Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions"
ModulePath "/usr/lib64/xorg/modules/drivers"
ModulePath "/usr/lib64/xorg/modules"
EndSection

or point them to wherever the nvidia drivers are ( you are looking for " nvidia_drv.so "
mine is " /usr/lib/xorg/modules/drivers/nvidia_drv.so "

blaker1990
7th April 2009, 01:43 PM
I have those lines, but it still says I don't have the extensions.
Here is my xorg.conf:


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder62) Tue Mar 24 06:16:11 PST 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder62) Tue Mar 24 06:15:32 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
ModulePath "/usr/lib64/xorg/modules/extensions"
ModulePath "/usr/lib64/xorg/modules/drivers"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "1"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL E171FPb"
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "DELL E171FPb"
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9800 GTX/9800 GTX+"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9800 GTX/9800 GTX+"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT-0: nvidia-auto-select +0+0"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT-1: nvidia-auto-select +0+0"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection


]

JohnVV
7th April 2009, 05:25 PM
and you did fallow the how to
http://forums.fedoraforum.org/showthread.php?t=173317
for installing compiz-fusion
what is the output of the "compiz-check utility " in the first post

blaker1990
9th April 2009, 10:21 PM
I installed compiz-fusion, ran it, and it says

Checking for Composite extension: not present.
aborting and using fallback: /usr/bin/kwin
kwin(17277): Compositing is not possible

st89
9th April 2009, 10:54 PM
Since installing the 64-bit nVidia driver for my 9800 gtx, I can't enable desktop effects because:
"Compositing is not supported on your system.
Required X extensions (XComposite and XDamage) are not available"

Is there any way around this?

I had a similar problem with my 8800GTX. I installed compiz fusion as well as doing:


sudo yum install kmod-nvidia

from http://www.fedorafaq.org/#nvidia and had no problems. I didn't download any drivers from nVidia direct.

blaker1990
9th April 2009, 11:10 PM
I tried to install kmod-nvidia but got:

Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
No package kmod-nvidia available.
Nothing to do

I assume there is an rpm I need to download, but don't know where.

st89
9th April 2009, 11:38 PM
I tried to install kmod-nvidia but got:

Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
No package kmod-nvidia available.
Nothing to do

I assume there is an rpm I need to download, but don't know where.

My bad. Login as su then do:


rpm -Uvh http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/livna-release-10.rpm http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

And it should work.