PDA

View Full Version : Unmount permanently



warkbt
6th April 2009, 05:09 PM
//SOLVED

Yeah it sound rare, but I have mount another OS partition in my fedora to transfer files. Nothing out of order, but when I restart my session it mount automatically even if I have unmount it before exiting...

There should be a file in my home directory that makes this, but which one?:confused:

I want not to mount automatically when starting my session...

jflesher
6th April 2009, 05:35 PM
Check your /etc/fstab
Maybe comment out the line with that device on it.

warkbt
6th April 2009, 05:41 PM
#
# /etc/fstab
# Created by anaconda on Sat Mar 28 00:55:33 2009
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
/dev/VolGroup00/LogVol03 /home ext3 defaults 1 2
/dev/VolGroup00/LogVol02 /tmp ext3 defaults 1 2
UUID=rubbish /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0


I don't find it, no ntfs?

Extra: it mount on /media/disk

jflesher
6th April 2009, 05:48 PM
Run fdisk -l and post it.

warkbt
6th April 2009, 06:48 PM
Here it goes:



fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x27262726

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2654 21317751 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 2655 2679 200812+ 83 Linux
/dev/sda3 2680 9729 56629125 8e Linux LVM

jflesher
6th April 2009, 06:55 PM
I see...
You can delete the folder "/media/disk" or maybe a .*fstab file in the media folder that has "/media/disk" in it.

You might look at this thread also
http://forums.fedoraforum.org/showthread.php?t=193000&highlight=unmount+drive

warkbt
6th April 2009, 07:17 PM
Solved


Navigate to SYSTEM / PREFERENCES / SYSTEM / AUTHORIZATIONS
Navigate to STORAGE
Select
1) Mount file systems from internal drives. Select user (you) click Revoke


Thanks.

jflesher
6th April 2009, 07:54 PM
For the Record:
By default on my system is:
Anyone: No
Console: No
Active Console: Admin Authentication (keep indefinitely)
Explicit Authentication:
(Blank)
***********
This may have fixed your configuration; but it would seem this is the default for most systems.
So clicking on Reset to Defaults and revoking any users would have just set this back to system default.
Maybe this has changed in F10 and was carried over from previous versions.